RPTools.net

Discussion and Support

Skip to content

It is currently Thu May 25, 2017 5:29 am 






Reply to topic  [ 87 posts ]  Go to page Previous  1, 2, 3, 4, 5, 6  Next

Previous topic | Next topic 

  Print view

Author Message
 Offline
Cave Troll
 
Joined: Tue Apr 07, 2009 7:19 pm
Posts: 70
 Post subject: Re: MapTool 1.3 Bugfix Build 74
PostPosted: Wed Sep 22, 2010 9:10 am 
same here


Top
 Profile  
 
User avatar  Offline
Dragon
 
Joined: Sat Jan 26, 2008 8:55 pm
Posts: 325
Location: West Warwick, RI
 Post subject: Re: MapTool 1.3 Bugfix Build 74
PostPosted: Wed Sep 22, 2010 6:57 pm 
Oh, forgot to mention; saw the template jitter Monday night! Offline you don't see it, but when I connected to my buddy's game with b74, the template center was jumping all over the place, as described. More of a visual bug than anything, though - didn't stop me from laying down templates where I wanted.


Top
 Profile  
 
User avatar  Offline
Dragon
 
Joined: Sat Oct 11, 2008 2:37 am
Posts: 739
Location: Limoges/Guéret, France
 Post subject: Re: MapTool 1.3 Bugfix Build 74
PostPosted: Thu Sep 23, 2010 4:00 am 
CoveredInFish wrote:
skester wrote:
using Build 74 I'm noticing a lot that when I load a campaign, not everything shows up on the map initially, but if I zoom in or out then everything pops up.

+1. Happened several times.


Me too.

_________________
ImageImageImageImage


Top
 Profile  
 
User avatar  Offline
Deity
 
Joined: Tue Jul 01, 2008 6:48 pm
Posts: 6237
 Post subject: Re: MapTool 1.3 Bugfix Build 74
PostPosted: Thu Sep 23, 2010 7:04 am 
I'm seeing the "not everything rendered in viewport" issue as well. Here's a couple screenshots to illustrate it, hopefully. This is in b74, just after opening a campaign file.

After opening, at the initial zoom of 100%, the viewport looks like this:
Image

There are normally 2 more of the large red library tokens in that set, off to the right of the 4 visible ones. They are not appearing on screen (which was the cause of some alarm at one point!). However, if I zoom out one click on my mouse-wheel (which takes the zoom level from 100% to 74%), (edited to add or move the map in any way), the other two appear as shown below. I guess requiring a redraw might correct an erroneous viewport size?

Image


Once I alter the zoom level, this particular visual glitch doesn't happen again until the next time the campaign is opened.

_________________

What I'm Working On

MapTool Tutorials:
Introduction to Tokens
Introduction to Properties
Introduction to Macro Writing
Introduction to Light and Sight


Last edited by Rumble on Thu Sep 23, 2010 9:30 am, edited 2 times in total.

Top
 Profile  
 
User avatar  Offline
Giant
 
Joined: Mon May 04, 2009 2:44 pm
Posts: 214
 Post subject: Re: MapTool 1.3 Bugfix Build 74
PostPosted: Thu Sep 23, 2010 8:22 am 
has this issue been looked at?

http://forums.rptools.net/viewtopic.php?f=3&t=16057

Thanks,
Skester


Top
 Profile  
 
 Offline
Giant
 
Joined: Thu May 13, 2010 12:52 pm
Posts: 118
 Post subject: Re: MapTool 1.3 Bugfix Build 74
PostPosted: Thu Sep 23, 2010 9:08 am 
I am also interested in knowing if this issue has been resolved, or is planned for upcoming bug fixes.

viewtopic.php?f=3&t=14443

Thank you


Top
 Profile  
 
User avatar  Offline
Site Admin
 
Joined: Mon Jun 12, 2006 12:20 pm
Posts: 12065
Location: Tampa, FL
 Post subject: Re: MapTool 1.3 Bugfix Build 74
PostPosted: Thu Sep 23, 2010 6:17 pm 
Anyone who is using the source code build: please test the pre-b75 release. I've added MetaGamer's patch for allowing an entire map to be exported, but I'm getting memory overflows in some cases. Note that you need to select the Advanced tab and choose the "ImageWriter" technique to test his new code. (Help messages in this regard will need to be added at some point; this is for testing only.)

skester wrote:
has this issue been looked at?

http://forums.rptools.net/viewtopic.php?f=3&t=16057

Thanks,
Skester

I posted the answer two days ago in my 11:50PM post. :)

Zandel wrote:
I am also interested in knowing if this issue has been resolved, or is planned for upcoming bug fixes.

viewtopic.php?f=3&t=14443

Thank you

Your answer is in the ChangeLog for b72.

(I could have just answered these questions directly, but that encourages people to ask questions that they could answer themselves. ;) No offense intended, guys!)


Top
 Profile  
 
User avatar  Offline
Giant
 
Joined: Mon May 04, 2009 2:44 pm
Posts: 214
 Post subject: Re: MapTool 1.3 Bugfix Build 74
PostPosted: Thu Sep 23, 2010 6:26 pm 
Thanks,

I wasn't entirely sure it was the same issue.

Skester


Top
 Profile  
 
User avatar  Offline
Demigod
 
Joined: Mon Jun 29, 2009 9:37 am
Posts: 3108
Location: Germany
 Post subject: Re: MapTool 1.3 Bugfix Build 74
PostPosted: Fri Sep 24, 2010 1:49 am 
Azhrei wrote:
Anyone who is using the source code build: please test the pre-b75 release. I've added MetaGamer's patch for allowing an entire map to be exported, but I'm getting memory overflows in some cases. Note that you need to select the Advanced tab and choose the "ImageWriter" technique to test his new code. (Help messages in this regard will need to be added at some point; this is for testing only.)


I always get this
java.lang.Error: Unresolved compilation problems:
The method putContent(InputStream) in the type Location is not applicable for the arguments (ImageWriter, BufferedImage)
The method putContent(InputStream) in the type Location is not applicable for the arguments (ImageWriter, ZoneImageGenerator)

at net.rptools.maptool.client.ui.ExportDialog.screenCapture(ExportDialog.java:615)
at net.rptools.maptool.client.ui.ExportDialog.exportButtonAction(ExportDialog.java:534)
at net.rptools.maptool.client.ui.ExportDialog.access$1(ExportDialog.java:493)
at net.rptools.maptool.client.ui.ExportDialog$1.actionPerformed(ExportDialog.java:423)
at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(Unknown Source)
at java.awt.Component.processMouseEvent(Unknown Source)
at javax.swing.JComponent.processMouseEvent(Unknown Source)
at java.awt.Component.processEvent(Unknown Source)
at java.awt.Container.processEvent(Unknown Source)
at java.awt.Component.dispatchEventImpl(Unknown Source)
at java.awt.Container.dispatchEventImpl(Unknown Source)
at java.awt.Component.dispatchEvent(Unknown Source)
at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
at java.awt.Container.dispatchEventImpl(Unknown Source)
at java.awt.Window.dispatchEventImpl(Unknown Source)
at java.awt.Component.dispatchEvent(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at net.rptools.maptool.client.swing.MapToolEventQueue.dispatchEvent(MapToolEventQueue.java:24)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.Dialog$1.run(Unknown Source)
at java.awt.Dialog$3.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.awt.Dialog.show(Unknown Source)
at java.awt.Component.show(Unknown Source)
at java.awt.Component.setVisible(Unknown Source)
at java.awt.Window.setVisible(Unknown Source)
at java.awt.Dialog.setVisible(Unknown Source)
at net.rptools.maptool.client.ui.ExportDialog.setVisible(ExportDialog.java:470)
at net.rptools.maptool.client.AppActions$2.execute(AppActions.java:201)
at net.rptools.maptool.client.AppActions$ClientAction.actionPerformed(AppActions.java:2623)
at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)
at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
at javax.swing.AbstractButton.doClick(Unknown Source)
at de.muntjak.tinylookandfeel.TinyMenuItemUI.doClick(TinyMenuItemUI.java:571)
at de.muntjak.tinylookandfeel.TinyMenuItemUI$MouseInputHandler.mouseReleased(TinyMenuItemUI.java:421)
at java.awt.Component.processMouseEvent(Unknown Source)
at javax.swing.JComponent.processMouseEvent(Unknown Source)
at java.awt.Component.processEvent(Unknown Source)
at java.awt.Container.processEvent(Unknown Source)
at java.awt.Component.dispatchEventImpl(Unknown Source)
at java.awt.Container.dispatchEventImpl(Unknown Source)
at java.awt.Component.dispatchEvent(Unknown Source)
at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
at java.awt.Container.dispatchEventImpl(Unknown Source)
at java.awt.Window.dispatchEventImpl(Unknown Source)
at java.awt.Component.dispatchEvent(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at net.rptools.maptool.client.swing.MapToolEventQueue.dispatchEvent(MapToolEventQueue.java:24)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)
when i export. Tried many different campaign files.


EDIT: nevermind. It seemed my updating wasnt complete.

EDIT2: I got a map export but it was pretty broken (fragments of images in the wrong place, other images missing). And there was a huge black area around my painted map - does the export code any trimming?
I will test more...

_________________
HELP: GETTING STARTED WITH MAPTOOLS - TUTORIALS, DOCS, VIDEOS, TOOLS, ETC.

most complete list of my maptool stuff


Top
 Profile  
 
User avatar  Offline
Deity
 
Joined: Fri May 12, 2006 7:56 pm
Posts: 6300
Location: Las Cruces, NM
 Post subject: Re: MapTool 1.3 Bugfix Build 74
PostPosted: Fri Sep 24, 2010 10:45 am 
Azhrei wrote:
Anyone who is using the source code build: please test the pre-b75 release. I've added MetaGamer's patch for allowing an entire map to be exported, but I'm getting memory overflows in some cases. Note that you need to select the Advanced tab and choose the "ImageWriter" technique to test his new code.

Did a couple dozen exports from both GM & Player clients in both modes with no errors produced. Except as noted below the maps were all correct.

  • The Fog hover help text is hosed.
  • Exporting GM View and just Fog selected produced a black image and not the current fog mask.
  • The Fog layer checkbox doesn't cause the export of a separate file as the hover help indicates but seems to just toggle whether or not the Fog layer is included in the rendered output.
  • The Visibility layer checkbox seems to be a toggle for showing a single (or selected?) tokens view or a party view and not saving the VBL as an image.
  • Disable Background Thread selection since it doesn't work.

_________________
Call me, Hex Boy.

Visit http://www.darkisle.com for photos of castles, cairns, standing stones, and other ancient sites in the British Isles.


Top
 Profile  
 
 Offline
Giant
 
Joined: Thu May 13, 2010 12:52 pm
Posts: 118
 Post subject: Re: MapTool 1.3 Bugfix Build 74
PostPosted: Fri Sep 24, 2010 12:01 pm 
Azhrei, thank you, I now know where to look, but I don't see viewtopic.php?f=3&t=14443 listed there, maybe I am missing it or not reading them right

Thanks


Top
 Profile  
 
User avatar  Offline
Deity
 
Joined: Tue Sep 11, 2007 6:31 pm
Posts: 5401
 Post subject: Re: MapTool 1.3 Bugfix Build 74
PostPosted: Fri Sep 24, 2010 4:53 pm 
Azhrei wrote:
jfrazierjr wrote:
Will you get my fix for Phergus and Dorpond's issue? I also have a few updates to tokenMove.

Got your patch, Joe; it's been applied and will be in b75. It does look like those changes will take care of the IndividualViews thing not working. :?

Edit: Not working 100%. When I switch to PlayerView (without a server running), there are some changes to the map, but the solid fog doesn't come up until I zoom in/out using the mouse wheel. Could it be that Ctrl-Shift-P is calling a repaint method before it sets up everything needed by the renderer...? I guess comparing the re-rendering process used by Ctrl-Shift-P with the one used by the mouse wheel might show why one displays properly and the other doesn't...?

Wanted to get b75 out this evening, but working against a deadline. Now I'm shooting for tomorrow evening. :|


Ok.. I sent a patch for this and the GM FOW opacity view thing to Azhrei

_________________
I save all my Campaign Files to DropBox. Not only can I access a campaign file from pretty much any OS that will run Maptool(Win,OSX, linux), but each file is versioned, so if something goes crazy wild, I can always roll back to a previous version of the same file.

Get your Dropbox 2GB via my referral link, and as a bonus, I get an extra 250 MB of space. Even if you don't don't use my link, I still enthusiastically recommend Dropbox..


Top
 Profile  
 
User avatar  Offline
Site Admin
 
Joined: Mon Jun 12, 2006 12:20 pm
Posts: 12065
Location: Tampa, FL
 Post subject: Re: MapTool 1.3 Bugfix Build 74
PostPosted: Fri Sep 24, 2010 6:30 pm 
Got some "Spousal Duties" tonight and tomorrow, but should have some time during the day. I will apply Joe's latest patch (the GM_FOW patch) and commit to SVN right now. Then b75 will be tomorrow and will include that patch unless something obviously breaks during my testing. ;)


Top
 Profile  
 
User avatar  Offline
Deity
 
Joined: Tue Sep 11, 2007 6:31 pm
Posts: 5401
 Post subject: Re: MapTool 1.3 Bugfix Build 74
PostPosted: Fri Sep 24, 2010 6:55 pm 
Azhrei wrote:
Got some "Spousal Duties" tonight and tomorrow, but should have some time during the day. I will apply Joe's latest patch (the GM_FOW patch) and commit to SVN right now. Then b75 will be tomorrow and will include that patch unless something obviously breaks during my testing. ;)


Question on builds and testing. From what I recall, the only thing that needs to be "fixed" when you build a local copy is the build.number file right? I assume nothing is uploaded anywhere correct? So, how about you do the build, make it available in a limited membership forum for the testers to check out for a few days and if it's good, move to the correct places for the zip and jnlp files. If problems that have to be fixed come up, just svn revert the build.number file, apply patches and redo.

Is that something that is possible with your current build process?

_________________
I save all my Campaign Files to DropBox. Not only can I access a campaign file from pretty much any OS that will run Maptool(Win,OSX, linux), but each file is versioned, so if something goes crazy wild, I can always roll back to a previous version of the same file.

Get your Dropbox 2GB via my referral link, and as a bonus, I get an extra 250 MB of space. Even if you don't don't use my link, I still enthusiastically recommend Dropbox..


Top
 Profile  
 
User avatar  Offline
Deity
 
Joined: Fri May 12, 2006 7:56 pm
Posts: 6300
Location: Las Cruces, NM
 Post subject: Re: MapTool 1.3 Bugfix Build 74
PostPosted: Fri Sep 24, 2010 11:36 pm 
It would be nice to get it in a few more hands for testing before release.

_________________
Call me, Hex Boy.

Visit http://www.darkisle.com for photos of castles, cairns, standing stones, and other ancient sites in the British Isles.


Top
 Profile  
 
Display posts from previous:  Sort by  
Reply to topic  [ 87 posts ]  Go to page Previous  1, 2, 3, 4, 5, 6  Next

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:

Who is online

In total there is 1 user online :: 0 registered, 0 hidden and 1 guest (based on users active over the past 5 minutes)
Most users ever online was 243 on Sun Nov 04, 2012 6:14 am

Users browsing this forum: No registered users and 1 guest





Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group

Style based on Andreas08 by Andreas Viklund

Style by Elizabeth Shulman