RPTools.net

Discussion and Support

Skip to content

It is currently Sat Dec 16, 2017 6:13 am 






Reply to topic  [ 40 posts ]  Go to page Previous  1, 2, 3  Next

Previous topic | Next topic 

  Print view

Author Message
User avatar  Offline
Great Wyrm
 
Joined: Sat Jun 21, 2008 12:07 am
Posts: 1950
 Post subject: Re: MapTool 1.3 Final (build 83)
PostPosted: Wed Feb 09, 2011 11:40 am 
Natha wrote:
Image
Great pic! :D

Isn't it funny how sometimes you see shapes in things. If you squint at this completely natural image, you can kinda see it as a big hand. :wink:

_________________
Drop-In Utilities:
My Spell Manager for D&D3.5 and PFRPG
My Inventory Manager for D&D and PFRPG, but more generally useable than that.
My Message Manager -- My Top-Down D&D Token Images
and my Custom Initiative & Status/Spell-Effect Tracker (work in progress, but functional).


Top
 Profile  
 
User avatar  Offline
Deity
 
Joined: Tue Nov 10, 2009 6:11 pm
Posts: 7967
Location: Bay Area
 Post subject: Re: MapTool 1.3 Final (build 83)
PostPosted: Wed Feb 09, 2011 12:13 pm 
I like the "nuke finger" image too. It's basically the same image but with a different finger set :twisted:

@Az, oh, I thought there was mention that when 1.3 is final there would be new icon for mac. I don't use mac, but I'd thought I'd bring this up, because I'm a pain in the butt like that :D

_________________
Downloads:


Top
 Profile  
 
User avatar  Offline
Giant
 
Joined: Thu Jun 17, 2010 1:50 pm
Posts: 123
Location: Maine
 Post subject: Re: MapTool 1.3 Final (build 83)
PostPosted: Wed Feb 09, 2011 1:29 pm 
Hooray! Congrats! Will download asap!

Everyone: Great achievement.


Top
 Profile  
 
 Offline
Dragon
 
Joined: Sat Dec 22, 2007 5:37 pm
Posts: 358
 Post subject: Re: MapTool 1.3 Final (build 83)
PostPosted: Wed Feb 09, 2011 1:48 pm 
Big time congrats to all involved!!!


Top
 Profile  
 
User avatar  Offline
Site Admin
 
Joined: Mon Jun 12, 2006 12:20 pm
Posts: 12103
Location: Tampa, FL
 Post subject: Re: MapTool 1.3 Final (build 83)
PostPosted: Wed Feb 09, 2011 4:08 pm 
Natha wrote:
Bad news though : Azhrei, I think you forgot to include in the SVN the "i18n_fr.properties" file I sent you some days ago.

Hm, I thought I'd done that but apparently not. :(

I have a file from you dated Jan 4th, then I have the one that I converted from iso8859 to utf8 that's dated Jan 23rd. And guess what? The one in MapTool's build directory is Jan 21st. Sigh.

It's updated now and I'll check it into SVN shortly. Thanks!

lmarkus001 wrote:
P.S. - Make sure you get the main page links updated... we don't want folks running that old stuff anymore!
http://www.rptools.net/index.php?page=launch

Yep! I will do another build to fix the drag-token-on-gridless map bug and include Natha's French translation, then I'll update the Launch page. :)

aliasmask wrote:
@Az, oh, I thought there was mention that when 1.3 is final there would be new icon for mac. I don't use mac, but I'd thought I'd bring this up, because I'm a pain in the butt like that :D

Really? I don't recall any "new icon" discussion? I don't see why there would be a new one specifically for that platform anyway... Although I had considered turning off the red notification badge in the dock bar. I'll go ahead and do that now.


Top
 Profile  
 
User avatar  Offline
Deity
 
Joined: Tue Nov 10, 2009 6:11 pm
Posts: 7967
Location: Bay Area
 Post subject: Re: MapTool 1.3 Final (build 83)
PostPosted: Wed Feb 09, 2011 4:31 pm 
Azhrei wrote:
aliasmask wrote:
@Az, oh, I thought there was mention that when 1.3 is final there would be new icon for mac. I don't use mac, but I'd thought I'd bring this up, because I'm a pain in the butt like that :D

Really? I don't recall any "new icon" discussion? I don't see why there would be a new one specifically for that platform anyway... Although I had considered turning off the red notification badge in the dock bar. I'll go ahead and do that now.

Yeah, the red dot thing with the build version on it. I remember someone saying they didn't like that or something.

_________________
Downloads:


Top
 Profile  
 
User avatar  Offline
Demigod
 
Joined: Mon Jun 29, 2009 9:37 am
Posts: 3108
Location: Germany
 Post subject: Re: MapTool 1.3 Final (build 83)
PostPosted: Wed Feb 09, 2011 5:04 pm 
Azhrei wrote:
Was this a gridless map?

Its a hex map, but the token is not "snap to grid".

Azhrei wrote:
Edit: It's been committed as revision 5641. Please try loading the same campaign with that version and moving the same token.

Tested and still throws NPE.

Since I have not much time right now I attach the campaign. Its an overland map and the "evil" npe-throwing token is an arrowy pointy "You are here" marker.

@aliasmask:
Someone didnt liked it but it came out it was pretty much a thing defined by MacOS. Probably not much to do about that...

_________________
HELP: GETTING STARTED WITH MAPTOOLS - TUTORIALS, DOCS, VIDEOS, TOOLS, ETC.

most complete list of my maptool stuff


Last edited by CoveredInFish on Wed Feb 09, 2011 6:55 pm, edited 1 time in total.

Top
 Profile  
 
User avatar  Offline
Giant
 
Joined: Thu Jun 17, 2010 1:50 pm
Posts: 123
Location: Maine
 Post subject: Re: MapTool 1.3 Final (build 83)
PostPosted: Wed Feb 09, 2011 5:43 pm 
Hi Azhrei & all,

I just did a full 3-hour session with my players with 1b83; everything ran fine except for two occurrences:

-"Player view" didn't give me the player view, but just a darkened out view. Something during session got switched, it felt like the opposite. Can't describe it better. I know that the server ran with individual views off. I could only see my player's light sources when I was on Player view, and never the other way round. This was, however, an old campaign I loaded. Previously used version was .b76.

-When grid was off, but tokens were set to snap to grid, and I had turned on Initiative, players who tried to move their impersonated tokens when it was _not_ their initiative crashed hard (served them right!). I asked them to send me their error reports, so here they are. This was reproducible, the crashes did not occur when initiative was off. It happened almost simultaneously for them, they disconnected, restarted, it went fine (outside initiative) and started happening again under initiative. While the simultaneity with the initiative could be accidental, I thought it's better to mention it. Good luck hunting!
Code:
java.lang.NullPointerException
    at net.rptools.maptool.client.tool.PointerTool.mouseMoved(PointerTool.java:577)
    at java.awt.AWTEventMulticaster.mouseMoved(Unknown Source)
    at java.awt.Component.processMouseMotionEvent(Unknown Source)
    at javax.swing.JComponent.processMouseMotionEvent(Unknown Source)
    at java.awt.Component.processEvent(Unknown Source)
    at java.awt.Container.processEvent(Unknown Source)
    at java.awt.Component.dispatchEventImpl(Unknown Source)
    at java.awt.Container.dispatchEventImpl(Unknown Source)
    at java.awt.Component.dispatchEvent(Unknown Source)
    at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
    at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
    at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
    at java.awt.Container.dispatchEventImpl(Unknown Source)
    at java.awt.Window.dispatchEventImpl(Unknown Source)
    at java.awt.Component.dispatchEvent(Unknown Source)
    at java.awt.EventQueue.dispatchEvent(Unknown Source)
    at net.rptools.maptool.client.swing.MapToolEventQueue.dispatchEvent(MapToolEventQueue.java:25)
    at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
    at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
    at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
    at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
    at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
    at java.awt.EventDispatchThread.run(Unknown Source)


and the other:
Code:
java.lang.NullPointerException
       at net.rptools.maptool.client.tool.PointerTool.mouseDragged(PointerTool.java:646)
       at java.awt.AWTEventMulticaster.mouseDragged(Unknown Source)
       at java.awt.Component.processMouseMotionEvent(Unknown Source)
       at javax.swing.JComponent.processMouseMotionEvent(Unknown Source)
       at java.awt.Component.processEvent(Unknown Source)
       at java.awt.Container.processEvent(Unknown Source)
       at java.awt.Component.dispatchEventImpl(Unknown Source)
       at java.awt.Container.dispatchEventImpl(Unknown Source)
       at java.awt.Component.dispatchEvent(Unknown Source)
       at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
       at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
       at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
       at java.awt.Container.dispatchEventImpl(Unknown Source)
       at java.awt.Window.dispatchEventImpl(Unknown Source)
       at java.awt.Component.dispatchEvent(Unknown Source)
       at java.awt.EventQueue.dispatchEvent(Unknown Source)
       at net.rptools.maptool.client.swing.MapToolEventQueue.dispatchEvent(MapToolEventQueue.java:25)
       at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
       at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
       at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
       at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
       at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
       at java.awt.EventDispatchThread.run(Unknown Source)


Top
 Profile  
 
User avatar  Offline
Dragon
 
Joined: Sat Oct 11, 2008 2:37 am
Posts: 739
Location: Limoges/Guéret, France
 Post subject: Re: MapTool 1.3 Final (build 83)
PostPosted: Wed Feb 09, 2011 5:57 pm 
:cry:
Out of 5 players (and myself and the PC used as server), one could'nt start b83 at all ... (though b82 still could be launched).

He had this error message each time (Windows XP, latest java), just after the MapTool splash screen showed up.
Quote:
ava.lang.NullPointerException
at net.rptools.lib.swing.SwingUtil.centerOver(SwingUtil.java:104)
at net.rptools.maptool.client.MapTool.getProfilingNoteFrame(MapTool.java:600)
at net.rptools.maptool.client.ui.macrobuttons.panels.SelectionPanel.init(SelectionPanel.java:108)
at net.rptools.maptool.client.ui.macrobuttons.panels.SelectionPanel.<init>(SelectionPanel.java:47)
at net.rptools.maptool.client.ui.MapToolFrame.<init>(MapToolFrame.java:233)
at net.rptools.maptool.client.MapTool.initialize(MapTool.java:567)
at net.rptools.maptool.client.MapTool.access$2(MapTool.java:533)
at net.rptools.maptool.client.MapTool$6.run(MapTool.java:1180)
at java.awt.event.InvocationEvent.dispatch(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at net.rptools.maptool.client.swing.MapToolEventQueue.dispatchEvent(MapToolEventQueue.java:25)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)


Then Maptool would hang and not launch fully, nor close itself. He had to kill the javaw.exe process each time.
We tried with the launcher, with the bats, closing all other non essential processes, unstalling/reinstalling java, CCleaning his PC ...
But no luck.

_________________
ImageImageImageImage


Top
 Profile  
 
User avatar  Offline
Site Admin
 
Joined: Mon Jun 12, 2006 12:20 pm
Posts: 12103
Location: Tampa, FL
 Post subject: Re: MapTool 1.3 Final (build 83)
PostPosted: Wed Feb 09, 2011 6:22 pm 
aliasmask wrote:
Yeah, the red dot thing with the build version on it. I remember someone saying they didn't like that or something.

Yeah, I can turn that off.

CoveredInFish wrote:
Since I have not much time right now I attach the campaign. Its an overland map and the "evil" npe-throwing token is an arrowy pointy "You are here" marker.

No campaign attached.

LeopoldVonRanke wrote:
-"Player view" didn't give me the player view, but just a darkened out view. Something during session got switched, it felt like the opposite. Can't describe it better. I know that the server ran with individual views off. I could only see my player's light sources when I was on Player view, and never the other way round. This was, however, an old campaign I loaded. Previously used version was .b76.

Ah, individual views off has probably not been tested much since all of the IV and IF code was added. I'll look into it. Is the campaign small enough to attach? Perhaps save a copy and delete all of the maps except one, if the problem is still exhibited?

Quote:
-When grid was off, but tokens were set to snap to grid, and I had turned on Initiative, players who tried to move their impersonated tokens when it was _not_ their initiative crashed hard (served them right!).

Hm. I remember a bug from a long time ago about tokens having SnapToGrid but being on a gridless map. Maybe it's related somehow. Thanks for the exception traces as that will help.

Natha wrote:
He had this error message each time (Windows XP, latest java), just after the MapTool splash screen showed up.

That's just... weird. That looks like it tried to open the profiling frame right away and the NPE happened when trying to center the non-existent window. :? I did add some logging to the CollectPerformanceData window, but that writes to a file and never tries to open a window. Hm. Thanks for the exception trace; I'll look into it.


Top
 Profile  
 
User avatar  Offline
Demigod
 
Joined: Mon Jun 29, 2009 9:37 am
Posts: 3108
Location: Germany
 Post subject: Re: MapTool 1.3 Final (build 83)
PostPosted: Wed Feb 09, 2011 6:32 pm 
Okay ... weird, I remember selecting that file in some dialog ... :?:

anyway, here it is:
Attachment:
warded man overland map.cmpgn [948.27 KiB]
Downloaded 101 times

_________________
HELP: GETTING STARTED WITH MAPTOOLS - TUTORIALS, DOCS, VIDEOS, TOOLS, ETC.

most complete list of my maptool stuff


Top
 Profile  
 
User avatar  Offline
Site Admin
 
Joined: Mon Jun 12, 2006 12:20 pm
Posts: 12103
Location: Tampa, FL
 Post subject: Re: MapTool 1.3 Final (build 83)
PostPosted: Wed Feb 09, 2011 7:53 pm 
LeopoldVonRanke wrote:
I just did a full 3-hour session with my players with 1b83; everything ran fine except for two occurrences:

Okay, this was already fixed in SVN. If my game doesn't happen tonight (looks like it won't), then I'll do another build right away.

CoveredInFish wrote:
Okay ... weird, I remember selecting that file in some dialog ... :?:

anyway, here it is:
Attachment:
warded man overland map.cmpgn

Thanks, I'll take a look.

Natha wrote:
Code:
Java.lang.NullPointerException
   at net.rptools.lib.swing.SwingUtil.centerOver(SwingUtil.java:104)
   at net.rptools.maptool.client.MapTool.getProfilingNoteFrame(MapTool.java:600)
   at net.rptools.maptool.client.ui.macrobuttons.panels.SelectionPanel.init(SelectionPanel.java:108)
   at net.rptools.maptool.client.ui.macrobuttons.panels.SelectionPanel.<init>(SelectionPanel.java:47)
   at net.rptools.maptool.client.ui.MapToolFrame.<init>(MapToolFrame.java:233)
   at net.rptools.maptool.client.MapTool.initialize(MapTool.java:567)
   at net.rptools.maptool.client.MapTool.access$2(MapTool.java:533)
   at net.rptools.maptool.client.MapTool$6.run(MapTool.java:1180)

The solution to this one is convoluted. It appears that the SelectionPanel reports some statistics to the profiling window and because I've added support for that same information to go to the log.txt file, a different path was taken while the SelectionPanel was being initialized. It tried to popup the profiling window before the main window had appeared. This is fixed in SVN.

I'm going to look at CiF's error and then put out a new build.


Top
 Profile  
 
User avatar  Offline
Site Admin
 
Joined: Mon Jun 12, 2006 12:20 pm
Posts: 12103
Location: Tampa, FL
 Post subject: Re: MapTool 1.3 Final (build 83)
PostPosted: Wed Feb 09, 2011 8:08 pm 
Azhrei wrote:
CoveredInFish wrote:
Okay ... weird, I remember selecting that file in some dialog ... :?:

anyway, here it is:
Attachment:
warded man overland map.cmpgn

Thanks, I'll take a look.

Okay, got it. I made a bunch of updates about a million levels deep in function calls, then forgot to update the call tree. Oops. :oops:

It's checked into SVN as 5648.


Top
 Profile  
 
User avatar  Offline
Deity
 
Joined: Fri Mar 20, 2009 4:40 am
Posts: 9427
Location: Netherlands
 Post subject: Re: MapTool 1.3 Final (build 83)
PostPosted: Thu Feb 10, 2011 4:36 am 
@Ahz: bloody hell, you're on a roll.

_________________
GETTING STARTED WITH MAPTOOLS - TUTORIALS, DOCS, VIDEOS, TOOLS, ETC

My stuff
Excel Tools: Table and Light editors
MT Tools: Bag of Tricks: Tools for Maptool, Dungeon Builder I, Dungeon Builder II,onMouseOverEvent and
DPI.
Frameworks: Dark Heresy, Rogue Trader, Deathwatch, Black Crusade, Only War, SET Card Game, RoboRally
Wiki: Debugging Tutorial, Speed Up Your Macros, Working With Two CODE Levels, Shortcut Keys, Avoiding Stack Overflow, READ THIS


Top
 Profile  
 
User avatar  Offline
Site Admin
 
Joined: Mon Jun 12, 2006 12:20 pm
Posts: 12103
Location: Tampa, FL
 Post subject: Re: MapTool 1.3 Final (build 83)
PostPosted: Thu Feb 10, 2011 10:20 am 
wolph42 wrote:
@Ahz: bloody hell, you're on a roll.

Heh. ;)

I had a business deadline for Friday and I got lucky and made a breakthrough Tuesday night/Wednesday morning. So I expect the rest of the job to go very quickly and I wanted to get 1.3 done and on the shelf, so to speak. So I devoted some more time to it. 8)

I'm so happy about the deadline that I'm blowing off work today and the wife and I are going to Busch Gardens. :)


Top
 Profile  
 
Display posts from previous:  Sort by  
Reply to topic  [ 40 posts ]  Go to page Previous  1, 2, 3  Next

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:

Who is online

In total there is 1 user online :: 0 registered, 0 hidden and 1 guest (based on users active over the past 5 minutes)
Most users ever online was 243 on Sun Nov 04, 2012 6:14 am

Users browsing this forum: No registered users and 1 guest





Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group

Style based on Andreas08 by Andreas Viklund

Style by Elizabeth Shulman