RPTools.net

Discussion and Support

Skip to content

It is currently Sun Dec 17, 2017 4:44 pm 






Reply to topic  [ 12 posts ] 

Previous topic | Next topic 

  Print view

Author Message
 Offline
Great Wyrm
 
Joined: Tue May 26, 2009 7:51 pm
Posts: 2060
Location: Philadelphia, PA
 Post subject: CharTool 1.0.b15 error loading D20 and Savage Worlds
PostPosted: Thu Oct 21, 2010 3:15 pm 
The newest Character Tool build errors with an IllegalState error when trying to load either the D20 or Savage Worlds rpgame files.


Top
 Profile  
 
User avatar  Offline
Site Admin
 
Joined: Mon Jun 12, 2006 12:20 pm
Posts: 12103
Location: Tampa, FL
 Post subject: Re: CharTool 1.0.b15 error loading D20 and Savage Worlds
PostPosted: Thu Oct 21, 2010 8:37 pm 
Stack trace, please?

On my Mac I can't get past "Game > Select Game". :(

I noticed that my checkout from SVN of the "web" project didn't seem to have everything in it. I had to grab copies of some of the stuff from the web site... :| That's probably not a good sign. ;)


Top
 Profile  
 
 Offline
Great Wyrm
 
Joined: Tue May 26, 2009 7:51 pm
Posts: 2060
Location: Philadelphia, PA
 Post subject: Re: CharTool 1.0.b15 error loading D20 and Savage Worlds
PostPosted: Fri Oct 22, 2010 12:06 pm 
How do I do a StackTrace? Are you talking the error in the .chartool log.txt file?


Top
 Profile  
 
User avatar  Offline
Site Admin
 
Joined: Mon Jun 12, 2006 12:20 pm
Posts: 12103
Location: Tampa, FL
 Post subject: Re: CharTool 1.0.b15 error loading D20 and Savage Worlds
PostPosted: Fri Oct 22, 2010 3:09 pm 
neofax wrote:
Are you talking the error in the .chartool log.txt file?

Yes.


Top
 Profile  
 
 Offline
Great Wyrm
 
Joined: Tue May 26, 2009 7:51 pm
Posts: 2060
Location: Philadelphia, PA
 Post subject: Re: CharTool 1.0.b15 error loading D20 and Savage Worlds
PostPosted: Tue Nov 23, 2010 1:59 pm 
I do not get a error in the log.txt file. However, the screen states:

"java.lang.IllegalStateException: Invalid property descriptor data."

Hopefully this will help.


Top
 Profile  
 
User avatar  Offline
RPTools Team
 
Joined: Tue Feb 07, 2006 1:07 am
Posts: 1766
Location: Austin, Tx
 Post subject: Re: CharTool 1.0.b15 error loading D20 and Savage Worlds
PostPosted: Wed Nov 24, 2010 11:53 am 
Are you pressing the Launch button from the RPTools site which uses WebStart to load? If so, try downloading the zip file from the site, unzipping it, and running the batch file. Sometimes running from Web Start will get an error reading files.


Top
 Profile  
 
 Offline
Kobold
 
Joined: Fri Oct 15, 2010 5:38 am
Posts: 20
 Post subject: Re: CharTool 1.0.b15 error loading D20 and Savage Worlds
PostPosted: Sat Dec 11, 2010 6:46 am 
I had the exact same problem as neofax, same error and everything. I also downloaded the zip and have this error. I hope this helps.


Top
 Profile  
 
User avatar  Offline
RPTools Team
 
Joined: Tue Feb 07, 2006 1:07 am
Posts: 1766
Location: Austin, Tx
 Post subject: Re: CharTool 1.0.b15 error loading D20 and Savage Worlds
PostPosted: Sat Dec 11, 2010 11:23 pm 
I'm having the same problem, it seems I tested with an older version of the file. I'll take a look.


Top
 Profile  
 
User avatar  Offline
RPTools Team
 
Joined: Tue Feb 07, 2006 1:07 am
Posts: 1766
Location: Austin, Tx
 Post subject: Re: CharTool 1.0.b15 error loading D20 and Savage Worlds
PostPosted: Sat Dec 11, 2010 11:42 pm 
It appears that Azhrei didn't update the game settings files when he updated the rest of CT for the new build. I'll talk to him and see if we can get that fixed.


Top
 Profile  
 
User avatar  Offline
Site Admin
 
Joined: Mon Jun 12, 2006 12:20 pm
Posts: 12103
Location: Tampa, FL
 Post subject: Re: CharTool 1.0.b15 error loading D20 and Savage Worlds
PostPosted: Sun Dec 12, 2010 12:35 am 
Yep, I didn't upload the contents of the "web" project from what Jay had put into SVN. I've done that now. Hopefully that's all of it.

(I need to add a README to the top level of the various projects to document their dependencies, both compile time and run time.)


Top
 Profile  
 
 Offline
Kobold
 
Joined: Fri Oct 15, 2010 5:38 am
Posts: 20
 Post subject: Re: CharTool 1.0.b15 error loading D20 and Savage Worlds
PostPosted: Sun Dec 12, 2010 2:06 am 
Tested a bit and I am pretty sure it is working now.


Top
 Profile  
 
 Offline
Kobold
 
Joined: Tue Jul 06, 2010 5:53 pm
Posts: 6
Location: Indiana, USA
 Post subject: Re: CharTool 1.0.b15 error loading D20 and Savage Worlds
PostPosted: Wed Feb 02, 2011 12:38 pm 
I have recently (as of yesterday) downloaded this latest version of CharTool, and I am experiencing the same problem as previously described in this thread. I unzipped the file to my normal RPTools directory of C:\rptools\chartool-1.0.b15\ and ran the program both by only clicking on the JAR file and launching the program via the BAT file. No log.txt file is generated anywhere capturing exceptions; all I get is a pop-up window that says "java.lang.IllegalStateException: Invalid property descriptor data." whenever the d20 3.5 or Savage Worlds characters are selected. It happens no matter which way I run the program.

I do not use either of these character sheets at the moment. (I might use 3.5 at some point in the future.) I'm not sure how to fix this error, but I do not think this has been fixed as Boerg alluded to previously.


Top
 Profile  
 
Display posts from previous:  Sort by  
Reply to topic  [ 12 posts ] 

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:

Who is online

In total there is 1 user online :: 0 registered, 0 hidden and 1 guest (based on users active over the past 5 minutes)
Most users ever online was 243 on Sun Nov 04, 2012 6:14 am

Users browsing this forum: No registered users and 1 guest





Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group

Style based on Andreas08 by Andreas Viklund

Style by Elizabeth Shulman