RPTools.net
http://forums.rptools.net/

Tokens not visible when "Show As Player" is on
http://forums.rptools.net/viewtopic.php?f=3&t=13692
Page 1 of 1

Author:  BuryGarcia [ Thu Mar 11, 2010 8:51 am ]
Post subject:  Tokens not visible when "Show As Player" is on

When I place my PC tokens on the map, and click "Show As Player", they disappear! When I click off "Show As Player" they are there, so I don't know what the problem could be.

I placed them on the Token layer, and I edited them to be PC-owned, and I assigned them to All Players, all to no avail. This hasn't happened to me before so I'm a little confused on why this is.

Any help would be greatly appreciated!

Author:  jfrazierjr [ Thu Mar 11, 2010 9:16 am ]
Post subject:  Re: Tokens not visible when "Show As Player" is on

BuryGarcia wrote:
When I place my PC tokens on the map, and click "Show As Player", they disappear! When I click off "Show As Player" they are there, so I don't know what the problem could be.

I placed them on the Token layer, and I edited them to be PC-owned, and I assigned them to All Players, all to no avail. This hasn't happened to me before so I'm a little confused on why this is.

Any help would be greatly appreciated!


Do you have lights, fog of war active, and the tokens have sight set or visible to players? There are several possible reasons why the players would not be able to see their tokens.

Author:  winkingbishop [ Thu Mar 11, 2010 2:22 pm ]
Post subject:  Re: Tokens not visible when "Show As Player" is on

One of the mistakes I frequently make when I place a token is to set the token down as an NPC. That will conceal tokens when you switch to player view. You can change the status of a token from NPC to PC from the Edit option.

Author:  BuryGarcia [ Fri Mar 12, 2010 3:38 pm ]
Post subject:  Re: Tokens not visible when "Show As Player" is on

I figured out the problem was related to having no light source set for the PC's when fog of war is turned on. I had their vision set to Lowlight vision, had them specified as PC's, but apparently you can't see yourself in total darkness... :)

And yes, I have watched the MapTool Video Tutorials... :)

Author:  filadelfiva [ Tue Jan 31, 2012 11:09 pm ]
Post subject:  Re: Tokens not visible when "Show As Player" is on

I am having a similar problem,

I am running version 1.3.b87 on Win7 64, on a plenty powerful machine.

When View => Show As Player, is checked the player tokens are no longer visible.

I have a server running, and it is passing information just fine,
The sevrer has "Players can reveal vision" and "auto Reveal On Movement" both checked.
The player token is set to PC,
has a light source,
Snaps to grid,
and is in the Token Layer.

Edit => Preferences => Interactions
New Maps Have Fog of War, Checked
New Maps Visible to Players, Checked
Tokens Start Snap to Grid, Checked
New tokens visible to players, Checked

Edit => Preferences => Application
Auto-Expose fog on token movement, checked

Auto reveal works as it should, but only from the GM view, all is working, except the player tokens not being visible to players. or when View => "Show As Player" is checked.

I feel like I am missing a basic setting or check box somewhere, but not finding it while going over and over.
I have been through the video tutorials, and though the PDFs, why this is eluding me is mildly frustrating.

Thank you kindly,

-Rabbit

Author:  Azhrei [ Sat Feb 04, 2012 12:05 am ]
Post subject:  Re: Tokens not visible when "Show As Player" is on

Show As Player is a GM tool to give a *basic* idea of what a player would see. But if you turn on "Individual Views" when you start the server (you didn't say if you turned this on or off), then the Show As Player must pick a player for you to pretend to be in order to show you a map as that player (right)? Except it can't know which player you want to be so you'll likely see nothing. (I'm not really sure what the code does in this case.)

If you want to test what a player sees, start a second instance of MapTool and connect to your server as a Player. Now you'll see what that player would see because you've actually logged into the server as that particular player. :)

Author:  Esheon [ Sat Feb 04, 2012 2:07 am ]
Post subject:  Re: Tokens not visible when "Show As Player" is on

One thing I've done is add "circle r3.5" (without the quotes) to normal vision and "circle r1.75" low-light vision. This gives every token with those vision types a circle that they can always see, and on a 5-foot-grid that circle's diameter is about equal to the diagonal length of one grid square.

If you wanted to limit that even further, circle r2.5 (1.25 for low-light, assuming your low-light effect is x2 vision range) would keep the vision wholly within the square the token is standing on (at least for a normal-vision character). Personally, I prefer to have the PCs able to juuuust see whats right beside them, but not know exactly what it is or how many there are. You could also choose to do "square r2.5" to illuminate the entire square the PC is standing on and nothing else.

Image

Normal: circle r3.5
Lowlight: circle x2 r1.75
NormalShort: circle r2.5

The character on the top right is using "NormalShort". The one in the center has "Lowlight", so any actual light source he has will be doubled in radius. The one on the bottom left just has "Normal" vision. The top left and bottom right are NPCs that are hidden from the PCs due to their lack of a light source. None of the PCs in that image have an active light source.

Of course, that doesn't help if you're using individual vision and it doesn't know which PC to display vision for... but that setting tends to horribly bog down my old machine, so I don't bother with it.

Author:  filadelfiva [ Sat Feb 04, 2012 11:02 pm ]
Post subject:  Re: Tokens not visible when "Show As Player" is on

Azhrei wrote:
If you want to test what a player sees, start a second instance of MapTool and connect to your server as a Player. Now you'll see what that player would see because you've actually logged into the server as that particular player. :)

I had just that setup, with the lappy set up next to the desktop as server.
I had this problem twice, once with my desktop(GM server) and lappy(player) setup, and once again with my lappy(GM server), and a friends lappy(secondary GM).

After fiddling with no avail for a while, and then in frustration posting here (hate not being able to figure it out for myself), I took one more stab at it, and without having closed MapTool, I think I may have reloaded the campaign (it's been a few days), and all worked as it should. Maybe a bug?

I have not fiddled with it since, but when I do I will give an update.

Thank you kindly for all of your help.
This being my second post on the forums, I would like to say that I am quite impressed with the community here.

Author:  Azhrei [ Mon Feb 06, 2012 9:00 am ]
Post subject:  Re: Tokens not visible when "Show As Player" is on

filadelfiva wrote:
I have not fiddled with it since, but when I do I will give an update.

Yes, please do. Thanks. :)

Quote:
Thank you kindly for all of your help.
This being my second post on the forums, I would like to say that I am quite impressed with the community here.

Thanks. We get that a lot. 8)

Author:  Vermilleo [ Sun Oct 23, 2016 1:47 pm ]
Post subject:  Re: Tokens not visible when "Show As Player" is on

Hello! Longtime user of Maptools, first time posting on the forums.

I haven't used Maptools in...several?...years, and I am just starting up a new campaign. I am having the same problem, that when I have "show as player" checked, I can't see any tokens, and the fog of war (the light gray you-have-seen-this-but-can't-right-now kind) covers everything.

I have players able to reveal movement, the tokens are set to PC, they're snapped to grid, tokens are visible to players, the maps are visible to players...

When vision is set to "off" (under the Map dropdown) I see the same thing as the players when I have "show as player" checked, namely everything not blocked by a VBL. When I have it set to "day" or "night" however, I cannot see any tokens when "show as player" is checked. This is regardless of the vision settings or light sources on the tokens. The PLAYERS can see everything the way they are supposed to according to the vision settings and light sources, so this is only a problem with me.

When a token is being moved, I CAN see it, along with the distance line. However, as soon as it is moved (the mouse key is released), I cannot see it anymore. If a player moves the token, it does reveal vision on my GM screen even when I have "show as player" clicked, but it's just that grayed-out FOW.

This is a problem that I have regardless of whether it's a different computer or I have opened several instances of Maptools on my own computer.

These problems ALSO only happen when the server is on. If it is off and I have "show as player" checked, everything works normally. That is, vision settings and light sources work the way they are supposed to and I can see all the visible tokens appropriately. So it must also be a server issue...somehow. Just to complicate the issue - these maps that I am using I made in a previous version of Maptools (1.3.b87 or 89, can't remember which). If I make a COMPLETELY NEW map in this version, everything works perfectly. But I don't want to remake all these old maps that I've got set up already!

I don't remember having this problem when I used Maptools before, and I have not changed any settings that should affect this. I am using v1.4.0.5 with Java version 8 update 101, build 1.8.0_101-b13.

If anyone has any advice as to how I can either fix this or somehow convert my old maps so they behave properly, I'd appreciate it. Thanks!

Author:  Vermilleo [ Sun Oct 23, 2016 1:51 pm ]
Post subject:  Re: Tokens not visible when "Show As Player" is on

EDIT to my previous post (since it's awaiting approval by a mod). Turns out I was wrong that creating a new map solves the problem. It doesn't. I hadn't actually started the server when I tried that. :(

Author:  aliasmask [ Sun Oct 23, 2016 1:55 pm ]
Post subject:  Re: Tokens not visible when "Show As Player" is on

Try adding your name to the owners list in the config of the token, but I'm not sure if that'll work either. The players view has always been kind of iffy in my experience. Also, try different server settings like turning off individual views.

Author:  Vermilleo [ Sun Oct 23, 2016 2:19 pm ]
Post subject:  Re: Tokens not visible when "Show As Player" is on

I'd tried everything you suggested...except, apparently, somehow, the solution is to turn individual views ON, which I had not done. Maybe I just misunderstand what that is supposed to do, but I would expect that to make it LESS likely to work.

Whatever, it works now and I'm happy :P

Thanks for your help!

Author:  dmmelkor [ Fri Nov 18, 2016 6:57 am ]
Post subject:  Re: Tokens not visible when "Show As Player" is on

Vermilleo wrote:
I'd tried everything you suggested...except, apparently, somehow, the solution is to turn individual views ON, which I had not done. Maybe I just misunderstand what that is supposed to do, but I would expect that to make it LESS likely to work.

Whatever, it works now and I'm happy :P

Thanks for your help!


I had exactly the same problem and turning individual views on was the only thing that helped. I also misunderstood that parameter ;-)
Got it working on a laptop with extended desktop and 2x maptools running.

Page 1 of 1 All times are UTC - 6 hours [ DST ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/