RPTools.net

Discussion and Support

Skip to content

It is currently Sat Oct 21, 2017 10:50 am 






Reply to topic  [ 3 posts ] 

Previous topic | Next topic 

  Print view

Author Message
 Offline
Giant
 
Joined: Tue Feb 05, 2008 3:39 pm
Posts: 196
 Post subject: Launcher problem with parameter -Xms
PostPosted: Fri Aug 26, 2016 8:14 am 
Hello guys,
Hoping someone can help out. I've downloaded the latest 1.4 build and am trying to get it to work.

I've updated to the latest java(64 bit), and when I start the launcher and attempt to start maptools the launcher just goes away.

I turned on the console to get error messages and I'm getting the following error:

Windows cannot find '-Xms64M'. Make sure you typed the name correctly, and then try again.

If I start maptools directly from the JAR it works, however the memory settings are set to minimum.

Here is my debug information from within Maptools:

==== MapTool Information ====
MapTool Version: 1.4.0.5
MapTool Home...: C:\Users\Jared\.maptool
Max mem avail..: 247M
Max mem used...: 53M

==== Java Information ====
Java Vendor.: Oracle Corporation
Java Home...: C:\Program Files (x86)\Java\jre1.8.0_101
Java Version: 1.8.0_101
Result of executing 'java -version':
............: Java(TM) SE Runtime Environment (build 1.8.0_101-b13)
............: Java HotSpot(TM) Client VM (build 25.101-b13, mixed mode, sharing)


==== OS Information ====
OS Name........: Windows 10
OS Version.....: 10.0
OS Architecture: x86
PATH...........: C:\Program Files (x86)\Java\jre1.8.0_101\bin;C:\WINDOWS\Sun\Java\bin;C:\WINDOWS\system32;C:\WINDOWS;C:\ProgramData\Oracle\Java\javapath;C:\Program Files (x86)\SAP\FrontEnd\SapGui;C:\Program Files (x86)\AMD APP\bin\x86_64;C:\Program Files (x86)\AMD APP\bin\x86;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\WINDOWS\System32\WindowsPowerShell\v1.0\;C:\Program Files\Java\jre7\bin;E:\xampp\htdocs\kill_team\app\Console;E:\xampp\php;E:\xampp\htdocs\kill_team\app\config;C:\Program Files (x86)\NVIDIA Corporation\PhysX\Common;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\WINDOWS\System32\WindowsPowerShell\v1.0\;C:\Program Files (x86)\QuickTime\QTSystem\;C:\Program Files (x86)\Skype\Phone\;C:\Program Files\Java\jre7;C:\Program Files\Microsoft Network Monitor 3\;C:\Program Files (x86)\Java\jre7\bin;.
Number of Procs: 8

==== User Information ====
User Name: Jared
User Home: C:\Users\Jared
User Dir.: G:\Dropbox\Game\maptools

==== Network Interfaces ====
Display Name..: Software Loopback Interface 1
Interface Name: lo
Address...: 127.0.0.1
Address...: 0:0:0:0:0:0:0:1

Display Name..: Qualcomm Atheros AR946x Wireless Network Adapter
Interface Name: wlan0
Address...: 192.168.1.48
Address...: fe80:0:0:0:645e:98bf:be6c:7c39%wlan0

Display Name..: Teredo Tunneling Pseudo-Interface
Interface Name: net0
Address...: 2001:0:9d38:90d7:24fd:3655:3f57:fecf
Address...: fe80:0:0:0:24fd:3655:3f57:fecf%net0

Host Address...: 192.168.1.48
Default Gateway: 192.168.1.1

==== Locale Information ====
Country.: Canada
Language: English
Locale..: English (Canada)
Variant.:

==== Display Information ====
Number of Displays: 3
Display 1: 3840x2160(32)
Display 2: 1920x1080(32)
Display 3: 1920x1200(32)

==== Internet Gateway Devices ====
Device Name.: RT-AC3100
Model Name..: RT-AC3100
Manufacturer: ASUSTeK Computer Inc.
Model Number: 3.0.0.4.380
Model Desc..: RT-AC3100
Firmware....: AsusWRT/3.0.0.4 UPnP/1.1 MiniUPnPd/1.9
External IP.: 198.84.170.81

Thanks!


Top
 Profile  
 
 Offline
Giant
 
Joined: Mon Aug 03, 2015 5:30 pm
Posts: 204
 Post subject: Re: Launcher problem with parameter -Xms
PostPosted: Fri Aug 26, 2016 10:53 am 
This part:

jsharen wrote:
Hello guys,
Java Home...: C:\Program Files (x86)\Java\jre1.8.0_101


Suggests to me that you do not, in fact, have 64 bit Java (and the behavior you describe is consistent with too high a memory setting on 32 bit). (The "Program Files (x86)" directory is where 64 bit Windows puts 32 bit programs.)

Are you certain you went to the manual download page for Java and got the 64 bit version?


Top
 Profile  
 
User avatar  Offline
Demigod
 
Joined: Sun Feb 25, 2007 11:53 am
Posts: 3729
Location: MD
 Post subject: Re: Launcher problem with parameter -Xms
PostPosted: Fri Aug 26, 2016 12:32 pm 
jsharen wrote:
I've updated to the latest java(64 bit), and when I start the launcher and attempt to start maptools the launcher just goes away.

Uninstall the java you currently have installed and get the Windows Offline 64 Bit version here: http://java.com/en/download/manual.jsp

_________________
Maptool is the Millennium Falcon of VTT's -- "She may not look like much, but she's got it where it counts."


Top
 Profile  
 
Display posts from previous:  Sort by  
Reply to topic  [ 3 posts ] 

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:

Who is online

In total there is 1 user online :: 0 registered, 0 hidden and 1 guest (based on users active over the past 5 minutes)
Most users ever online was 243 on Sun Nov 04, 2012 6:14 am

Users browsing this forum: No registered users and 1 guest





cron

Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group

Style based on Andreas08 by Andreas Viklund

Style by Elizabeth Shulman