RPTools.net

Discussion and Support

Skip to content

It is currently Fri Oct 20, 2017 11:21 am 






Reply to topic  [ 4 posts ] 

Previous topic | Next topic 

  Print view

Author Message
 Offline
Kobold
 
Joined: Thu Jun 04, 2009 8:08 am
Posts: 8
Location: Scotland
 Post subject: Parser module broken
PostPosted: Mon Oct 04, 2010 4:11 pm 
Today I thought I would try out a Trunk build for Maptool using Eclipse and found that:
1. Needed to add the clientserver project (no big deal)
2. parser project seems to be broken.

Digging down into the issues it seems that on 28/08 a bunch of ExpressionParser* files got removed from net/rptools/parser and this has broken other files that try and import/use them :(

Looking at the commit that did the damage it says:
Cleaned up CaseInsensitiveHashMap in prep for adding an XStream "Converter"
and it does modify that file, but also deletes 6 other files.

Known issue ?


Top
 Profile  
 
User avatar  Offline
Cave Troll
 
Joined: Sun Aug 29, 2010 7:58 pm
Posts: 45
Location: Seattle, WA
 Post subject: Re: Parser module broken
PostPosted: Mon Oct 04, 2010 4:41 pm 
The parser module is a bit tricky to build at the moment. There is a grammar file (expression.g I think) that is used with the ANTLR v2 tool to generate the files that you are missing.

From what I understand there is an ANTLR v2 eclipse plugin that will allow the project to be built from SVN trunk.

I'm currently working on a conversion to a Maven build system. It is still a ways off, but once that is ready, it will be much easier to build from source, and the ANTLR eclipse plugin won't be necessary.


Top
 Profile  
 
User avatar  Offline
Site Admin
 
Joined: Mon Jun 12, 2006 12:20 pm
Posts: 12101
Location: Tampa, FL
 Post subject: Re: Parser module broken
PostPosted: Mon Oct 04, 2010 6:30 pm 
I'll look at it later tonight, but it builds for me (just did that last night). You probably just need the ANTLR plugin installed and ANTLR turned on. I posted somewhere in this forum (or the subforum) about my experiences with ANTLR -- that may help you.


Top
 Profile  
 
 Offline
Kobold
 
Joined: Thu Jun 04, 2009 8:08 am
Posts: 8
Location: Scotland
 Post subject: Re: Parser module broken
PostPosted: Tue Oct 05, 2010 1:28 pm 
Problem sorted. It was an issue on my end. As well as updating to the latest HEAD I also allowed eclipse to updated itself and that broke the ALTLR build for me.

Forcing the ANTLR build made it all work again.

Sorry for the noise.


Top
 Profile  
 
Display posts from previous:  Sort by  
Reply to topic  [ 4 posts ] 

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:

Who is online

In total there is 1 user online :: 0 registered, 0 hidden and 1 guest (based on users active over the past 5 minutes)
Most users ever online was 243 on Sun Nov 04, 2012 6:14 am

Users browsing this forum: No registered users and 1 guest





Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group

Style based on Andreas08 by Andreas Viklund

Style by Elizabeth Shulman