RPTools.net
http://forums.rptools.net/

Contributing to MapTool 1.4
http://forums.rptools.net/viewtopic.php?f=86&t=25794
Page 3 of 3

Author:  Jagged [ Fri Nov 20, 2015 4:41 am ]
Post subject:  Re: Contributing to MapTool 1.4

Craig wrote:
rplib and dicetool have been added to github.
To build them you will need to specify the -PVersion=<version> option.
For example to install the pom into your local repository
Code:
./graldew install -pVersion=1.4.0.1-SNAPSHOT


I think this might be a typo, or the Windows environment is different. I had to type:
Code:
gradlew -Pversion=1.4.0.1-SNAPSHOT install

Author:  smaudet2 [ Sat Mar 04, 2017 12:26 pm ]
Post subject:  Re: Contributing to MapTool 1.4

Jagged wrote:
Craig wrote:
rplib and dicetool have been added to github.
To build them you will need to specify the -PVersion=<version> option.
For example to install the pom into your local repository
Code:
./graldew install -pVersion=1.4.0.1-SNAPSHOT


I think this might be a typo, or the Windows environment is different. I had to type:
Code:
gradlew -Pversion=1.4.0.1-SNAPSHOT install


Where?

I'm staring at what I was pretty sure was maptool github...unless I'm not up to date somehow...there's nothing that looks like 'dicetool' in here.

Definitely, not the same thing as on the front page.

Be nice if you could actually find it...trying to use gradle is an excersize in how multiple technologies like to blow up when you throw them together... I may just continue porting the old dicetool to pom if I can't get gradle to work/find this supposed dicetool (which isn't in the correct repository if it even exists).

Author:  username [ Sat Jan 06, 2018 11:01 am ]
Post subject:  Re: Contributing to MapTool 1.4

I suggest to upgrade the gradle version to at least 2.3 (2.14 is currently the latest 2.x version), unless there is a specific reason to stay older than that. 2.1 has some specific problems with eclipse oxygen and the buildship gradle plugin, which is the mostly used gradle plugin in eclipse. Apparently this is a general problem (https://github.com/eclipse/buildship/issues/607) they're not likely to fix. With 2.1, I'm stuck to the CLI.

(I can provide a pull request.)

Page 3 of 3 All times are UTC - 6 hours [ DST ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/