RPTools.net

Discussion and Support

Skip to content

It is currently Thu Nov 23, 2017 1:42 pm 




Forum rules


Posting now open to all registered forum users.



Reply to topic  [ 19 posts ]  Go to page Previous  1, 2

Previous topic | Next topic 

  Print view

Author Message
User avatar  Offline
TheBard
 
Joined: Tue Mar 21, 2006 7:26 pm
Posts: 3483
Location: Austin, Tx
 Post subject: Re: 1.4 Build 01
PostPosted: Wed Sep 16, 2015 10:48 am 
Possible Bug

I'm having a problem with Wiki: getNotes() and Wiki: getGMNotes(). If I call the function without a note set it errors out. It works fine if there is a note present.

To reproduce:
Drop Token
Impersonate Token
in chat window [r:getNotes()]
witness error

Edit token
Place text in Notes box
Press OK to save
in chat window [r:getNotes()]
witness the note text returned.

[edit: Craig submitted fix]

_________________
ImageImage ImageImageImageImage
Support RPTools by shopping
Image
Image


Top
 Profile  
 
 Offline
Great Wyrm
 
Joined: Sun Jun 22, 2008 6:53 pm
Posts: 2102
Location: Melbourne, Australia
 Post subject: Re: 1.4 Build 01
PostPosted: Wed Sep 16, 2015 6:38 pm 
archmagi1 wrote:
Is there a big change log for this over 1.3b91? I skimmed upthread, but was just wondering if those snips were the definitive list?

The change list in the announcement was it.
Didn't want to change too much for 1.4.0 and break compatibility so that people on the latest 1.3 would have somewhere to move to easily that works correctly with a recent version of java.


Top
 Profile  
 
User avatar  Offline
Great Wyrm
 
Joined: Mon Sep 15, 2008 8:27 am
Posts: 1180
Location: Bristol, UK
 Post subject: Re: 1.4 Build 01
PostPosted: Fri Dec 11, 2015 8:56 am 
When I run the current trunk, I get the following run time warnings:
Code:
AppResourceLoader.loadImage failed: net/rptools/lib/image/icons/shape_handles.png
AppResourceLoader.loadImage failed: net/rptools/lib/image/icons/eraser.png
AppResourceLoader.loadImage failed: net/rptools/lib/image/icons/paintbrush.png
AppResourceLoader.loadImage failed: net/rptools/lib/image/icons/contrast_high.png


I assume these should be in the "rpib-1.4.0.1.jar" ? I can see them in the 1.0.b134 version, but not in the 1.4.0.1 version.


Top
 Profile  
 
 Offline
Great Wyrm
 
Joined: Sun Jun 22, 2008 6:53 pm
Posts: 2102
Location: Melbourne, Australia
 Post subject: Re: 1.4 Build 01
PostPosted: Fri Dec 11, 2015 11:33 pm 
Jagged wrote:
When I run the current trunk, I get the following run time warnings:
Code:
AppResourceLoader.loadImage failed: net/rptools/lib/image/icons/shape_handles.png
AppResourceLoader.loadImage failed: net/rptools/lib/image/icons/eraser.png
AppResourceLoader.loadImage failed: net/rptools/lib/image/icons/paintbrush.png
AppResourceLoader.loadImage failed: net/rptools/lib/image/icons/contrast_high.png


I assume these should be in the "rpib-1.4.0.1.jar" ? I can see them in the 1.0.b134 version, but not in the 1.4.0.1 version.

I have added these files to the repository. For some reason they are getting excluded by the .gitignore -- I need to revisit all the .gitignore files at some stage.
A new rplib jar has been created (1.4.0.2), because gradle caches the dependency versions for 24 hours by default you will need to run gradle with --refresh-dependencies to pick up the new jar if you have tried in last 24 hours.


Top
 Profile  
 
Display posts from previous:  Sort by  
Reply to topic  [ 19 posts ]  Go to page Previous  1, 2

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:

Who is online

In total there are 2 users online :: 0 registered, 0 hidden and 2 guests (based on users active over the past 5 minutes)
Most users ever online was 243 on Sun Nov 04, 2012 6:14 am

Users browsing this forum: No registered users and 2 guests





Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group

Style based on Andreas08 by Andreas Viklund

Style by Elizabeth Shulman