RPTools.net
http://forums.rptools.net/

Corrupted Cmpgn File: Java.lang.NullPointerException
http://forums.rptools.net/viewtopic.php?f=86&t=27355
Page 1 of 1

Author:  RedWyrm13 [ Sun Sep 24, 2017 7:28 am ]
Post subject:  Corrupted Cmpgn File: Java.lang.NullPointerException

Hello, I've recently had a problem with a Campaign File of mine corrupting.

It started when I tried saving my Campaign when Maptool began spamming me with an error message (unfortunately, I don't have a screen-cap). When I tried reloading the campaign, it would not open, giving me the messages:

"Error while reading campaign file.
Java.lang.NullPointerException"

... and...

"Cannot determine campaign file format; not loaded."

Unfortunately, I was too late to copy the autosave.

The map was very memory intensive, so I think that may have been the major cause of the problem.

Below is a Link of the Campaign File. I think the problem has something to do with something in the content.xml file.

https://www.dropbox.com/s/emg0d6u6dtah4 ... cmpgn?dl=0

Do you think the Campaign can be repaired, or the maps recovered? I would like to avoid having to result to my older save. I'd have lost weeks of work.

Also, would you need anything else?

Author:  wolph42 [ Sun Sep 24, 2017 8:08 am ]
Post subject:  Re: Corrupted Cmpgn File: Java.lang.NullPointerException

You didn't backup regularly...happens to the best of us, but the price is usually high, the reward though a sour lesson.

Options left:

- did you have the file in a dropbox folder? If so: it has a repository function and you can retrieve old saves upto one month. (If not: Hint: next time store it in a dropbox folder)
- have you checked the .maptool dir, there are backups and autosaves stored there, perhaps there's something in there
- you can try zip repair function (as the .cmpgn is actuall a .zip file)
after that, you can have a look around the forum as you're not the first, but beyond extracting your images your basically screwed. Stuff that *might* work is reparing the zip and then manually start deleting parts (maps) from the xlm file to see if you can get the part out that renders the error...

Author:  RPTroll [ Sun Sep 24, 2017 12:48 pm ]
Post subject:  Re: Corrupted Cmpgn File: Java.lang.NullPointerException

Although it doesn't help you, there are efforts underway that include backup and recovery campaign files. Not sure it would help in this instance but it would open up more options.

Author:  RedWyrm13 [ Sun Sep 24, 2017 12:55 pm ]
Post subject:  Re: Corrupted Cmpgn File: Java.lang.NullPointerException

wolph42, I only recently put it in the Dropbox so that I can link it to you guys.

As for backups, when I went to check and copy them, it deleted them... meaning I don't have any.

I also tried to repair the ZIP, but it didn't seem to work for me...

If it's irreparable, I might as well quit... I'm not going to spend another month of work repairing what has been lost. I don't have the patience or temper to deal with having to start over.

Author:  RedWyrm13 [ Sun Sep 24, 2017 1:30 pm ]
Post subject:  Re: Corrupted Cmpgn File: Java.lang.NullPointerException

wolph42 wrote:
You didn't backup regularly...happens to the best of us, but the price is usually high, the reward though a sour lesson.

Options left:

- did you have the file in a dropbox folder? If so: it has a repository function and you can retrieve old saves upto one month. (If not: Hint: next time store it in a dropbox folder)
- have you checked the .maptool dir, there are backups and autosaves stored there, perhaps there's something in there
- you can try zip repair function (as the .cmpgn is actuall a .zip file)
after that, you can have a look around the forum as you're not the first, but beyond extracting your images your basically screwed. Stuff that *might* work is reparing the zip and then manually start deleting parts (maps) from the xlm file to see if you can get the part out that renders the error...


I only put it in the Dropbox after it stopped working properly so I can upload it for someone to take a look at.

My backups and autosaves deleted themselves as I was about ready to try loading them up...

And as for the Zip Repair Function... when I tried it, it didn't fix anything, despite saying that it "Successfully Repaired It".


If there is nothing I can do, and it's irreparable, I might as well quit... I don't have the patience to try rebuilding several weeks worth of work, especially when I was almost finished.

Maybe I'll come up with some other campaign idea that goes nowhere.

Author:  Full Bleed [ Sun Sep 24, 2017 8:33 pm ]
Post subject:  Re: Corrupted Cmpgn File: Java.lang.NullPointerException

RedWyrm13 wrote:
The map was very memory intensive, so I think that may have been the major cause of the problem.

Share your Help>Gather Debug Information

You probably are running a bad memory configuration.

Quote:
Below is a Link of the Campaign File. I think the problem has something to do with something in the content.xml file.

Do you think the Campaign can be repaired, or the maps recovered? I would like to avoid having to result to my older save. I'd have lost weeks of work.

Also, would you need anything else?

I tried repairing it but it still threw an error even after I removed some corrupted assets... what version of MT were you using?

Author:  RedWyrm13 [ Mon Sep 25, 2017 7:04 am ]
Post subject:  Re: Corrupted Cmpgn File: Java.lang.NullPointerException

Full Bleed wrote:
RedWyrm13 wrote:
The map was very memory intensive, so I think that may have been the major cause of the problem.

Share your Help>Gather Debug Information

You probably are running a bad memory configuration.

Quote:
Below is a Link of the Campaign File. I think the problem has something to do with something in the content.xml file.

Do you think the Campaign can be repaired, or the maps recovered? I would like to avoid having to result to my older save. I'd have lost weeks of work.

Also, would you need anything else?

I tried repairing it but it still threw an error even after I removed some corrupted assets... what version of MT were you using?


I should probably reconfigure my Memory for my 4 GB Laptop. I got the 8 GB Laptop to run an older save better... without the Memory issues.

I believe I'm using 1.4.0.0.

Page 1 of 1 All times are UTC - 6 hours [ DST ]
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/