RPTools.net

Discussion and Support

Skip to content

It is currently Fri Nov 24, 2017 10:04 am 






Reply to topic  [ 18 posts ]  Go to page Previous  1, 2

Previous topic | Next topic 

  Print view

Author Message
 Offline
Kobold
 
Joined: Thu Jun 24, 2010 11:47 am
Posts: 1
 Post subject: Re: Inittool 1.1b9 not loading
PostPosted: Thu Jun 24, 2010 12:35 pm 
Running OS X 10.6.4

Of all the tools, InitTool-11b9-512m-2m.jnlp is the only one that didn't run correctly. It would hang at the splash screen @ the end of it's initial DL.

A little poking around shows that the app is throwing an exception here...

FormManagerUtils.openPackgedForm failed: net/rptools/inittool/resources/forms/creatureIndexCard.jfrm
java.io.IOException: Stream closed
...


BTW: The zip version of the app (1.1b9) opened with 'Launch InitTool.sh' works fine.


Top
 Profile  
 
User avatar  Offline
RPTools Team
 
Joined: Tue Feb 07, 2006 1:07 am
Posts: 1766
Location: Austin, Tx
 Post subject: Re: Inittool 1.1b9 not loading
PostPosted: Sat Aug 07, 2010 12:51 pm 
For some reason, Web Start will not read some of the data files within the jar. It only does this some times and it only does it for certain people. I've seen it fail on one build, then rebuilt the same code and have it work for the next. I've never been able to figure out why so that I can fix it. The only workaround I have is to download the zip file and run it locally.


Top
 Profile  
 
User avatar  Offline
RPTools Team
 
Joined: Tue Feb 07, 2006 1:07 am
Posts: 1766
Location: Austin, Tx
 Post subject: Re: Inittool 1.1b9 not loading
PostPosted: Sat Aug 07, 2010 1:21 pm 
Azhrei wrote:
Jay, here's the command line as reported by ps that Java Web Start created when launched on OSX. Does anything here stand out to you?

snip...

Interestingly enough, that filename tacked onto the end, /var/tmp/javawsXRQJqa, which is obviously a temporary file of some kind, doesn't exist on my system :?
Nothing stands out because it is all going to start the Web Start application. That last file is just a string parameter to the application, so it could be a temp file that Web Start was going to create for logging or whatever.


Top
 Profile  
 
Display posts from previous:  Sort by  
Reply to topic  [ 18 posts ]  Go to page Previous  1, 2

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:

Who is online

In total there is 1 user online :: 0 registered, 0 hidden and 1 guest (based on users active over the past 5 minutes)
Most users ever online was 243 on Sun Nov 04, 2012 6:14 am

Users browsing this forum: No registered users and 1 guest





Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group

Style based on Andreas08 by Andreas Viklund

Style by Elizabeth Shulman