RPTools.net

Discussion and Support

Skip to content

It is currently Sat Dec 16, 2017 3:50 pm 






Reply to topic  [ 27 posts ]  Go to page Previous  1, 2

Previous topic | Next topic 

  Print view

Author Message
User avatar  Offline
Dragon
 
Joined: Mon May 31, 2010 6:03 am
Posts: 515
Location: Blagnac, France
 Post subject: Re: Wiki updating problem
PostPosted: Fri Jul 01, 2011 9:00 am 
Azhrei wrote:
For those who have seen the "blank page" symptom: try right-clicking on the blank page and choosing "view source". Post into a CODE block whatever you get.

It might be that some headers are being generated but no content; that might be helpful in tracking down where the problem is.

Perhaps an exact timestamp for when you received the blank page would help as well. It would let Craig look at the available logs (if there are any) and maybe correlate a specific log entry back to the problem...

OK, so using FireFox 4.0.1, FireBug extension gives me:

for URL:
Code:
http://lmwcs.com/maptool/index.php?title=MapTool_ChangeLog_%28by_build_version%29&action=submit

The received page code is:
Code:
<html>
<head></head>
<body></body>
</html>

Looking in the DOM I can dig out:
Code:
wikEdAutoUpdate="Fri, 01 Jul 2011 13:03:31 GMT"
wikEdSummaryHistory="Minor%20title%20level%20change%0AAdding%20a%20second%20usage%20with%20map%20parameter%0AAnother%20way%20to%20do%20it"

But I don't know much about DOM and I am surely missing useful informations. Tell me what you might need.


My last attempt gave me the network request (sent):

header:
Code:
Host   lmwcs.com
User-Agent   Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Accept   text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
Accept-Language   fr,fr-fr;q=0.8,en-us;q=0.5,en;q=0.3
Accept-Encoding   gzip, deflate
Accept-Charset   ISO-8859-1,utf-8;q=0.7,*;q=0.7
Keep-Alive   115
Connection   keep-alive
Cookie   lmwcscom_mwwikidb_mtd_UserName=JML; lmwcscom_mwwikidb_mtd__session=67c235bc58f1d250f3ccc841cbda86da; lmwcscom_mwwikidb_mtd_UserID=586

Post:
Code:
wpAntispam   
wpSection   
wpStarttime   20110701133155
wpEdittime   20110624205048
wpScrolltop   0
wpSummary   Minor title level change
wpSave   Save page
wpAutoSummary   d41d8cd98f00b204e9800998ecf8427e
wpEditToken   d5c018653c44c946fa2250c005150fcd+\


I get much similar informations from Safari 5.0.5.
I don't really know if anything is of some use in all this. Just tell me.


Top
 Profile  
 
User avatar  Offline
Site Admin
 
Joined: Mon Jun 12, 2006 12:20 pm
Posts: 12103
Location: Tampa, FL
 Post subject: Re: Wiki updating problem
PostPosted: Fri Jul 01, 2011 12:38 pm 
It looks like all of these users are using non-English locales, right? Maybe that's the common factor?

Is anyone here using a non-English locale and having the wiki work properly?

What brought this to my attention was the mention of the Windows code page in wolph's post. It's interesting that IE got a response and the others didn't (for wolph, anyway). Perhaps a bug in the language switch stuff?


Top
 Profile  
 
User avatar  Offline
Deity
 
Joined: Fri Mar 20, 2009 4:40 am
Posts: 9427
Location: Netherlands
 Post subject: Re: Wiki updating problem
PostPosted: Fri Jul 01, 2011 12:47 pm 
Save the ip address I've got everything in English. Though not sure whether it's uk or us.

_________________
GETTING STARTED WITH MAPTOOLS - TUTORIALS, DOCS, VIDEOS, TOOLS, ETC

My stuff
Excel Tools: Table and Light editors
MT Tools: Bag of Tricks: Tools for Maptool, Dungeon Builder I, Dungeon Builder II,onMouseOverEvent and
DPI.
Frameworks: Dark Heresy, Rogue Trader, Deathwatch, Black Crusade, Only War, SET Card Game, RoboRally
Wiki: Debugging Tutorial, Speed Up Your Macros, Working With Two CODE Levels, Shortcut Keys, Avoiding Stack Overflow, READ THIS


Top
 Profile  
 
User avatar  Offline
Dragon
 
Joined: Mon May 31, 2010 6:03 am
Posts: 515
Location: Blagnac, France
 Post subject: Re: Wiki updating problem
PostPosted: Fri Jul 01, 2011 1:18 pm 
Azhrei wrote:
It looks like all of these users are using non-English locales, right? Maybe that's the common factor?

I thought it might be a factor and that's why I mentioned french(european) ISP in my first post, but forgot to say french OS and browsers :oops:

wolph42 wrote:
Save the ip address I've got everything in English. Though not sure whether it's uk or us.

Including OS ?


Top
 Profile  
 
User avatar  Offline
Deity
 
Joined: Fri Mar 20, 2009 4:40 am
Posts: 9427
Location: Netherlands
 Post subject: Re: Wiki updating problem
PostPosted: Fri Jul 01, 2011 4:28 pm 
Yup
Btw I remember that rumble had the problem too. He's in the us.

_________________
GETTING STARTED WITH MAPTOOLS - TUTORIALS, DOCS, VIDEOS, TOOLS, ETC

My stuff
Excel Tools: Table and Light editors
MT Tools: Bag of Tricks: Tools for Maptool, Dungeon Builder I, Dungeon Builder II,onMouseOverEvent and
DPI.
Frameworks: Dark Heresy, Rogue Trader, Deathwatch, Black Crusade, Only War, SET Card Game, RoboRally
Wiki: Debugging Tutorial, Speed Up Your Macros, Working With Two CODE Levels, Shortcut Keys, Avoiding Stack Overflow, READ THIS


Top
 Profile  
 
User avatar  Offline
Dragon
 
Joined: Mon May 31, 2010 6:03 am
Posts: 515
Location: Blagnac, France
 Post subject: Re: Wiki updating problem
PostPosted: Tue Jul 05, 2011 7:43 am 
OK, I think I found what my problem was (and may be Wolph42's also). And I'm a bit ashamed because it seems I didn't pay attention to a message displayed in bold font:

Quote:
WARNING: This page is 34 kilobytes long; some browsers may have problems editing pages approaching or longer than 32kb. Please consider breaking the page into smaller sections.

:oops: :oops: :oops:

This explains why I (and others) was able to create a new page today, able to edit small parts with the right wing Edit link, but not big parts or big pages. It looks like I didn't try to edit small parts for a while.

So does anyone know how to get around this limitation ?


Top
 Profile  
 
User avatar  Offline
Deity
 
Joined: Fri Mar 20, 2009 4:40 am
Posts: 9427
Location: Netherlands
 Post subject: Re: Wiki updating problem
PostPosted: Tue Jul 05, 2011 7:51 am 
Nope not the problem, unless EVERY page is larger than 32kb. Ok I didn't try EVERY page but I did try a small one like Wiki: json.reverse().
by the way I *can* see the preview, I just cant submit the change.

I also remember trying to change small pages, which lacked a lot of info that I figured out painstakingly... as this was never saved I fear its all lost. I did send some updates to craig, but I don't think he ever did anything with it.

_________________
GETTING STARTED WITH MAPTOOLS - TUTORIALS, DOCS, VIDEOS, TOOLS, ETC

My stuff
Excel Tools: Table and Light editors
MT Tools: Bag of Tricks: Tools for Maptool, Dungeon Builder I, Dungeon Builder II,onMouseOverEvent and
DPI.
Frameworks: Dark Heresy, Rogue Trader, Deathwatch, Black Crusade, Only War, SET Card Game, RoboRally
Wiki: Debugging Tutorial, Speed Up Your Macros, Working With Two CODE Levels, Shortcut Keys, Avoiding Stack Overflow, READ THIS


Top
 Profile  
 
User avatar  Offline
Dragon
 
Joined: Mon May 31, 2010 6:03 am
Posts: 515
Location: Blagnac, France
 Post subject: Re: Wiki updating problem
PostPosted: Tue Jul 05, 2011 8:24 am 
wolph42 wrote:
Nope not the problem, unless EVERY page is larger than 32kb. Ok I didn't try EVERY page but I did try a small one like Wiki: json.reverse().

OK, you're right on this one. But I'm wondering if this has got something to do with templates in this one case ?
I was just glad to find out that I'm able to make some updates when I thought I wasn't able to do a single one.

wolph42 wrote:
by the way I *can* see the preview, I just cant submit the change.

Same for me. So, it seems we're finally on the same boat. At least, this narrows things a bit :|


Top
 Profile  
 
User avatar  Offline
Dragon
 
Joined: Mon May 31, 2010 6:03 am
Posts: 515
Location: Blagnac, France
 Post subject: Re: Wiki updating problem
PostPosted: Tue Jul 05, 2011 10:01 am 
OK, having made a few more testing.

At first I thought the difference between articles or parts that could be updated and others lied in their size, but then wolph42 pointed at a small article that we couldn't update. I noticed there were quite a few templates used in this article and wondered if this could get in the way.

After some tests on different articles and parts of them, I think updating is taken into account if, and only if, the edited text and all preceding text in the article is "pure" text without images, code formatting or templates.

Among others, I did the following test on the Introduction to Mapping article:

  1. I'm unable to update the whole article.
  2. Updating the First Things First: What is MapTool? part is OK.
  3. Updating the About this Guide part is OK.
  4. Updating the Getting Images into your MapTool Resource Library part fails: there's images in it.
  5. Updating any following part fails, even if there only text in it..

Can someone tell me if I'm right or not ?


Top
 Profile  
 
User avatar  Offline
Demigod
 
Joined: Mon Jun 29, 2009 9:37 am
Posts: 3108
Location: Germany
 Post subject: Re: Wiki updating problem
PostPosted: Tue Jul 05, 2011 11:55 am 
I definitly tried updating (whole) pages without images and it failed.

_________________
HELP: GETTING STARTED WITH MAPTOOLS - TUTORIALS, DOCS, VIDEOS, TOOLS, ETC.

most complete list of my maptool stuff


Top
 Profile  
 
User avatar  Offline
Dragon
 
Joined: Mon May 31, 2010 6:03 am
Posts: 515
Location: Blagnac, France
 Post subject: Re: Wiki updating problem
PostPosted: Tue Jul 05, 2011 12:09 pm 
I think almost anything else than text is a problem. I know "code" blocks were the only thing in the way in one of my tests, and I think templates also, so, if any of those were in these pages…

But more thorough testing is surely needed. Sadly I might not have much time for this in the coming days.


Top
 Profile  
 
User avatar  Offline
Dragon
 
Joined: Mon May 31, 2010 6:03 am
Posts: 515
Location: Blagnac, France
 Post subject: Re: [Solved] Wiki updating problem
PostPosted: Tue Jul 19, 2011 7:34 am 
Registered users able to edit again thanks to Craig.

See Temp Wiki Update Thread.


Top
 Profile  
 
Display posts from previous:  Sort by  
Reply to topic  [ 27 posts ]  Go to page Previous  1, 2

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:

Who is online

In total there is 1 user online :: 0 registered, 0 hidden and 1 guest (based on users active over the past 5 minutes)
Most users ever online was 243 on Sun Nov 04, 2012 6:14 am

Users browsing this forum: No registered users and 1 guest





Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group

Style based on Andreas08 by Andreas Viklund

Style by Elizabeth Shulman