Friend's MapTool doesn't seem to save autologs (Mac versions)

Thoughts, Help, Feature Requests, Bug Reports, Developing code for...

Moderators: dorpond, trevor, Azhrei

Forum rules
PLEASE don't post images of your entire desktop, attach entire campaign files when only a single file is needed, or generally act in some other anti-social behavior. :)
Post Reply
Glitch(TMG)
Cave Troll
Posts: 40
Joined: Wed Oct 27, 2010 11:42 am

Friend's MapTool doesn't seem to save autologs (Mac versions)

Post by Glitch(TMG) »

So, I have a friend who has been in MapTool based games with me for quite a few years now, going on 6-7 years. But circa a year ago, they've been having a problem; MapTool does not save textchat autologs for them anymore. They are not inclined to make a thread here themselves, so I have gathered all the information that I could think of to ask from them to see if anyone around here might know something about this. Here is all the information I got from them:
  • They are running MapTool on a Mac OS.
  • The -current- Mac OS version they are on is Big Sur 11.0.1
  • Before that, they were on Sierra or Catalina, they can't remember exactly which version, and Mac forced an upgrade to Big Sur at some point that they were really trying to avoid (it broke a bunch of work programs they were using).
  • The issue cropped up -before- they ended up forced onto Big Sur.
  • There was also the MapTool "forced" update in february of this year, with the exploits discovered in pre-1.8 versions of MapTool and everyone had to update (We are currently using 1.8.0).
  • The issue began -before- this update, as well. I think the version we had been using at that time was 1.4.0.0.
  • Particularly, the issue began a year or longer ago, but no idea precisely when.
  • So whatever "triggered" this issue is currently unknown.
  • It happened before the OS update and the Maptool update, and persisted through both.
  • Weirdly, there WAS one or two times recently where MapTool actually DID save an autolog when my friend had checked. It was just two random days this year and spread apart from each other, no idea what made them different from any other days.
  • Unfortunately, friend -also- doesn't remember the filepath -where- these autologs were originally created, as friend has moved the files since then. And I know nothing about Macs, so I have no idea what would be expected there.
  • Friend has attempted many different ways of resolving this problem, including full uninstalling and reinstalling of MapTool, "redoing the setup", and following various "guides" on things to check. None have worked to restore autologging function.
  • Their current MapTool chatlog autosave settings are:
    • Time between chat log autosaves: 5 minutes
    • Autosave chat log filename: chatlog-%1$tF-%1R.html
    • File Sync Directory: Users/UserName/Desktop/Maptools/Maptool Chat Logs (which I guess is the filepath that friend couldn't remember earlier, maybe?)

So, might anyone who is familiar with the Mac-ified versions of MapTool have any ideas as to what this issue might be, or what might be causing it? If more information is needed, I can try to pass on further questions.

Glitch(TMG)
Cave Troll
Posts: 40
Joined: Wed Oct 27, 2010 11:42 am

Re: Friend's MapTool doesn't seem to save autologs (Mac versions)

Post by Glitch(TMG) »

So, uh, IS there anyone who can help out with this, or has any ideas...?

User avatar
Azhrei
Site Admin
Posts: 12079
Joined: Mon Jun 12, 2006 1:20 pm
Location: Tampa, FL

Re: Friend's MapTool doesn't seem to save autologs (Mac versions)

Post by Azhrei »

Have the user check their MapTool Preferences. In particular, the contents of the chat log-related fields (chat log filename and the auto save duration). Nothing else in your description points to a problem.

Glitch(TMG)
Cave Troll
Posts: 40
Joined: Wed Oct 27, 2010 11:42 am

Re: Friend's MapTool doesn't seem to save autologs (Mac versions)

Post by Glitch(TMG) »

Azhrei wrote:
Wed Oct 06, 2021 10:43 pm
Have the user check their MapTool Preferences. In particular, the contents of the chat log-related fields (chat log filename and the auto save duration). Nothing else in your description points to a problem.
Yes, I...already gave their current MapTool preference settings for autologs? Again, as already stated in my initial message;

•Their current MapTool chatlog autosave settings are:
◦Time between chat log autosaves: 5 minutes
◦Autosave chat log filename: chatlog-%1$tF-%1R.html
◦File Sync Directory: Users/UserName/Desktop/Maptools/Maptool Chat Logs (which I guess is the filepath that friend couldn't remember earlier, maybe?)

Those are what they report their settings as. And yet, autologs are not saving (I am pretty sure one of the things friend has also already tried was running filename searches through their system, and could not turn up any missing logs, but I suppose I can double-check that as well). That's the whole problem here, there appears to be -some- sort of bug in the system that is preventing the autologs from saving/appearing (other than the bizarrely random two days scattered in the last six months that somehow did end up saving logs apparently).

Is there any other data I can try to gather that might help pinpoint and diagnose this issue?

User avatar
Azhrei
Site Admin
Posts: 12079
Joined: Mon Jun 12, 2006 1:20 pm
Location: Tampa, FL

Re: Friend's MapTool doesn't seem to save autologs (Mac versions)

Post by Azhrei »

I'm running macOS Big Sur 11.6 on a MBP. MapTool is at 1.9.3.


That last entry, FileSyncDirectory, I'm not familiar with but I don't believe it has any bearing on the chat log autosave. (I'll do some research and post back here when I have any more info on it.)

I had my chat log autosave turned off, so I set it to 5 minutes and it immediately triggered a save. The file appeared under MAPTOOL_DATADIR/autosave/. The filename pattern I used (which was the default) means the file was named chatlog-2021-10-08-11-39.html.

The MAPTOOL_DATADIR defaults to ~/.maptool-rptools — they can verify this on the last tab of the Preferences panel. (Ignore the tooltip as it has the wrong default listed in it — the code has been updated but not the tooltip. I'll file a bug report.)

Edit: Oh, I forgot. If they look under MAPTOOL_DATADIR/logs they should see the maptool.log file. It's a regular text file. They should open it in TextEdit or similar to view it. It should have an entry in it every time the chat autosave is started and every time it finishes. I see entries like this in mine with no error messages:

Code: Select all

2021-10-08 11:39:13.022 INFO  net.rptools.maptool.client.ChatAutoSave - Saving log to '/Users/franke/.maptool-rptools/autosave/chatlog-2021-10-08-11-39.html'
2021-10-08 11:39:13.026 INFO  net.rptools.maptool.client.ChatAutoSave - Log saved

Glitch(TMG)
Cave Troll
Posts: 40
Joined: Wed Oct 27, 2010 11:42 am

Re: Friend's MapTool doesn't seem to save autologs (Mac versions)

Post by Glitch(TMG) »

Azhrei wrote:
Fri Oct 08, 2021 11:47 am
I'm running macOS Big Sur 11.6 on a MBP. MapTool is at 1.9.3.


That last entry, FileSyncDirectory, I'm not familiar with but I don't believe it has any bearing on the chat log autosave. (I'll do some research and post back here when I have any more info on it.)

I had my chat log autosave turned off, so I set it to 5 minutes and it immediately triggered a save. The file appeared under MAPTOOL_DATADIR/autosave/. The filename pattern I used (which was the default) means the file was named chatlog-2021-10-08-11-39.html.

The MAPTOOL_DATADIR defaults to ~/.maptool-rptools — they can verify this on the last tab of the Preferences panel. (Ignore the tooltip as it has the wrong default listed in it — the code has been updated but not the tooltip. I'll file a bug report.)

Edit: Oh, I forgot. If they look under MAPTOOL_DATADIR/logs they should see the maptool.log file. It's a regular text file. They should open it in TextEdit or similar to view it. It should have an entry in it every time the chat autosave is started and every time it finishes. I see entries like this in mine with no error messages:

Code: Select all

2021-10-08 11:39:13.022 INFO  net.rptools.maptool.client.ChatAutoSave - Saving log to '/Users/franke/.maptool-rptools/autosave/chatlog-2021-10-08-11-39.html'
2021-10-08 11:39:13.026 INFO  net.rptools.maptool.client.ChatAutoSave - Log saved
Hrm. If "FyleSyncDirectory" doesn't actually have anything to do with chatlog autosaves, then why is it grouped there in the first place? That's weird.


Anyway, tried to have my friend look for the stuff. "MAPTOOL_DATADIR" is not actually the name of an any actual folder, and it was very confusing that you had asked to look for that (it irritated my friend very badly to be asked for something that's not real, and it's because of their frustrations with this that they haven't bothered to come here and ask themselves).

That said, there's a further weird thing. Friend said they did run a search on their harddrive for the "maptool-rptools" string, as well as simply the strings "maptool" and "rptools" and...nothing turned up. At all. They HAVE maptool on their computer obviously, but it seems no such folders or files exist with those names, which is...very bizarre. I don't know what that says. Do you have any idea what that says?

In any case, can you also please be more specific, and actually specify the real, actual, full filepath my friend needs to follow and look for to find these things?

User avatar
Azhrei
Site Admin
Posts: 12079
Joined: Mon Jun 12, 2006 1:20 pm
Location: Tampa, FL

Re: Friend's MapTool doesn't seem to save autologs (Mac versions)

Post by Azhrei »

Glitch(TMG) wrote:
Tue Oct 12, 2021 2:07 pm
Hrm. If "FyleSyncDirectory" doesn't actually have anything to do with chatlog autosaves, then why is it grouped there in the first place? That's weird.
I said I wasn't aware that it had any effect, not that I knew it didn't have any effect.
Anyway, tried to have my friend look for the stuff. "MAPTOOL_DATADIR" is not actually the name of an any actual folder, and it was very confusing that you had asked to look for that (it irritated my friend very badly to be asked for something that's not real, and it's because of their frustrations with this that they haven't bothered to come here and ask themselves).
Huh?

I guess it wasn't clear when I said that "The MAPTOOL_DATADIR defaults to ~/.maptool-rptools" that it meant that if he hadn't changed it, it would be the specified directory. And I pointed out where to look in the MapTool Preferences to see what the directory actually was if he had changed it.

Please understand that MapTool has a lot of customization options and people sometimes do weird things when they install software (in choosing install directories and such). I tried to head off any confusion about the location in case the user had changed it.
That said, there's a further weird thing. Friend said they did run a search on their harddrive for the "maptool-rptools" string, as well as simply the strings "maptool" and "rptools" and...nothing turned up. At all. They HAVE maptool on their computer obviously, but it seems no such folders or files exist with those names, which is...very bizarre. I don't know what that says. Do you have any idea what that says?
They searched for the wrong name (it's missing the leading period). However, even if I search for that name (the correct one) it still doesn't turn up. Since macOS treats filenames starting with a period as "hidden", that isn't too surprising by itself.

If your user will open Finder and type Shift-Cmd-G, they will get the option to just type the directory name they want to visit. They should type in the name I provided, above, (~/.maptool-rptools) to be taken directly to the directory in question. I feel the need to point out again that this is only if they haven't changed it. You didn't indicate whether they had done so.

Hopefully they know how to maneuver in Finder and locate the autosave directory and the files inside it.
In any case, can you also please be more specific, and actually specify the real, actual, full filepath my friend needs to follow and look for to find these things?
I can't specify the "real, actual, full filepath" because it's under their home directory and you didn't tell me what their username is.

I did the next best thing and gave you a symbolic name that refers to the right location, which your user apparently didn't know how to use. Hopefully the Shift-Cmd-G keystroke I provided will help.

In terms of what has changed on macOS in the last few versions, there have been many security updates that Apple has implemented. For example, the first time an application tries to access the Desktop folder, macOS will display a confirmation prompt asking whether such access should be allowed. If the user clicked Deny, then they would have to go into System Preferences > Security & Privacy, then navigate to the Privacy tab and reset fields under Files and Folders. But none of this is MapTool support, it's just a general macOS thing, something that every macOS user should be familiar with. Or if they're not, there's always Google. (Google knows the answer. Google knows everything. :mrgreen: )

Glitch(TMG)
Cave Troll
Posts: 40
Joined: Wed Oct 27, 2010 11:42 am

Re: Friend's MapTool doesn't seem to save autologs (Mac versions)

Post by Glitch(TMG) »

Azhrei wrote:
Tue Oct 12, 2021 7:27 pm
They searched for the wrong name (it's missing the leading period). However, even if I search for that name (the correct one) it still doesn't turn up. Since macOS treats filenames starting with a period as "hidden", that isn't too surprising by itself.
Hmm. So as it turns out, my friend actually was aware of MacOS hidden folders already and -had- accounted for that. I asked them to read the rest your post, and they said they had already tried all of the other things you mentioned too (they knew more about it already than I did)...which is why this issue has pissed them off so badly. The folders just...are not there. They aren't anywhere that can be found. It's really really weird.

In any case, friend had given up on trying to get chatsave autologs to work long ago. I was the one pushing for looking at it again by trying to get help from here, and now they REALLY want nothing more to do with any of it, even though according to your last information we were trying to find maptool's internal system log rather than the chatlogs this time. *shrug* Oh well.

I at least very much appreciate you trying to help anyway, Azhrei, and I thank you for your time!

User avatar
Azhrei
Site Admin
Posts: 12079
Joined: Mon Jun 12, 2006 1:20 pm
Location: Tampa, FL

Re: Friend's MapTool doesn't seem to save autologs (Mac versions)

Post by Azhrei »

Glitch(TMG) wrote:
Mon Oct 18, 2021 2:35 pm
[...] even though according to your last information we were trying to find maptool's internal system log rather than the chatlogs this time. *shrug* Oh well.
If you find one, you find the other.

It's interesting that the user chose to ignore the full pathname I provided (the ~/.maptool-rptools pathname) and claim that they can't find anything. Heck, I even provided the super-secret-shortcut-key-that-only-experts-know that allows them to just type it in directly! (And now I'll get in trouble with the cabal that manages such things. :mrgreen: )

It's probably just some kind of misunderstanding in the terminology or something.
I at least very much appreciate you trying to help anyway, Azhrei, and I thank you for your time!
Sorry it didn't work out.

Glitch(TMG)
Cave Troll
Posts: 40
Joined: Wed Oct 27, 2010 11:42 am

Re: Friend's MapTool doesn't seem to save autologs (Mac versions)

Post by Glitch(TMG) »

Azhrei wrote:
Mon Oct 18, 2021 2:47 pm
If you find one, you find the other.
Ah, good to know.
Azhrei wrote:
Mon Oct 18, 2021 2:47 pm
It's interesting that the user chose to ignore the full pathname I provided (the ~/.maptool-rptools pathname) and claim that they can't find anything. Heck, I even provided the super-secret-shortcut-key-that-only-experts-know that allows them to just type it in directly! (And now I'll get in trouble with the cabal that manages such things. :mrgreen: )
No, they did try the full pathname (I did not accurately report what they had done cuz I can't actually see it), and the shortcut key, and knows about hidden folders, and everything else you mentioned. The folders still aren't there, somehow. Hence why my friend is so infuriated by the situation and just doesn't want to bother with it anymore.

User avatar
Azhrei
Site Admin
Posts: 12079
Joined: Mon Jun 12, 2006 1:20 pm
Location: Tampa, FL

Re: Friend's MapTool doesn't seem to save autologs (Mac versions)

Post by Azhrei »

Glitch(TMG) wrote:
Wed Oct 20, 2021 4:17 pm
The folders still aren't there, somehow. Hence why my friend is so infuriated by the situation and just doesn't want to bother with it anymore.
Hm. Given that MT won't run if it can't create or access that directory, I'm somewhat incredulous.

Since they've given up and are too frustrated to make further attempts, there's nothing else for us to do at this point. As I said, I'm sorry it didn't work out for them.

Glitch(TMG)
Cave Troll
Posts: 40
Joined: Wed Oct 27, 2010 11:42 am

Re: Friend's MapTool doesn't seem to save autologs (Mac versions)

Post by Glitch(TMG) »

Azhrei wrote:
Wed Oct 20, 2021 10:48 pm
Since they've given up and are too frustrated to make further attempts, there's nothing else for us to do at this point. As I said, I'm sorry it didn't work out for them.
Is a shame, yeah. And again, I do thank you and appreciate you taking the time to attempt to help, at least.

Post Reply

Return to “MapTool”