Image Table issues

Thoughts, Help, Feature Requests, Bug Reports, Developing code for...

Moderators: Azhrei, dorpond, trevor

Forum rules
PLEASE don't post images of your entire desktop, attach entire campaign files when only a single file is needed, or generally act in some other anti-social behavior. :)
Post Reply
xavram
Dragon
Posts: 808
Joined: Tue Apr 20, 2010 8:22 pm

Image Table issues

Post by xavram »

This is probably a long shot, but here goes.

I have this puzzle in my game, where the players have to rotate these rings to try to spell out something. Looks like this...

Image

Then I have campaign macros, for each ring, "Rotate Left" and "Rotate Right". Macors look like...

[h : tokenId = findToken("1stRing")]
[h : currentRot = getTokenFacing(tokenId)]
[h : currentRot = currentRot - 45]
[h : setTokenFacing(currentRot, tokenId)]

And then each ring has an image table, that shows the image rotated for every 45 degree increment. Yes, each ring is its own Figure token.

So this works just fine when I test, all the rings rotate in the correct direction, changing the orientation of the letters.

But the players in my game...some of them see the rings just fine. Some see the big red ? for the ring....which appears or disappears depending on the rotation of the ring.

Am I doing something wrong? Why is that as the DM, I can see the image changing just fine but for some players it works and for others it doesn't.

Its an online game, so was really hoping this would be a fun, interactive puzzle for the players...now its just a semi-disaster!

xavram
Dragon
Posts: 808
Joined: Tue Apr 20, 2010 8:22 pm

Re: Image Table issues

Post by xavram »

oh, the image tables are set up like so...

-180 - -158
-157 - -113
-112- -59
-68 - -23
-22 - 22
23 - 68
69 - 112
113 - 157
158 - 180

Copied this from whoever originally posted how the tables should work...Jagged, maybe?

User avatar
aliasmask
Deity
Posts: 8580
Joined: Tue Nov 10, 2009 6:11 pm
Location: Bay Area

Re: Image Table issues

Post by aliasmask »

I suspect if they clear their cache and the restart MT that it may fix itself.

xavram
Dragon
Posts: 808
Joined: Tue Apr 20, 2010 8:22 pm

Re: Image Table issues

Post by xavram »

ugh, not sure about that as a solution, given that it takes a while to load the campaign/map. We're playing online, not over a LAN, so load times are significant and I'm a bit concerned that next week if that doesn't work, we're right back in the same mess. Shoot...

bubblobill
Cave Troll
Posts: 97
Joined: Sun Jan 24, 2010 3:07 pm

Re: Image Table issues

Post by bubblobill »

You can try different things to trigger a redraw. Clicking elsewhere, moving the map, zooming, switching maps. Sometimes it helps.

xavram
Dragon
Posts: 808
Joined: Tue Apr 20, 2010 8:22 pm

Re: Image Table issues

Post by xavram »

Yeah, did all those things, but that's a bit clunky in game, where the players will be freely rotating the the rings back and forth to try to figure out the puzzles.

I simplified things, took the puzzle out of the map itself and just used a "normal" image, where they set the facing with the buttons. No image tables, so I think this will work...it just won't look as cool/immersive.

Post Reply

Return to “MapTool”