[Dark Heresy-RT-Deathwatch-BC-OW] W40K-RPG_FW v8.5.0

MapTool campaign files that encapsulate properties, tokens, and macros for a particular ruleset or game world. "Framework" is often abbreviated "FW".

Moderators: Azhrei, dorpond, trevor, giliath, Gamerdude, jay, Mr.Ice

Forum rules
This forum is LOCKED. If a thread belongs here, use the "Report" feature of the post to let a moderator know to move it. General discussion should occur in the User Creations or MapTool forums.
User avatar
wolph42
Deity
Posts: 9703
Joined: Fri Mar 20, 2009 5:40 am
Location: Netherlands
Contact:

Re: [Dark Heresy-RT-Deathwatch-BC-OW] W40K-RPG_FW v8.4.5

Post by wolph42 »

UPDATE 8.4.5: There's a bug in campaign properties, introduced with newer versions of MT who can't properly handle {} statements. Hence here an upgrade for the campaign properties:
W40K Campaign Properties Update.zip
(5.46 MiB) Downloaded 13 times
EITHER import the campaign properties in campaign settings OR manually copy paste the properties in the corresponding properties. The latter is more hassle, but the former could screw up home made stuff like additional states (which will be reverted to the original state).

runecheese30
Kobold
Posts: 2
Joined: Sat Apr 18, 2020 11:17 pm

Re: [Dark Heresy-RT-Deathwatch-BC-OW] W40K-RPG_FW v8.4.5

Post by runecheese30 »

Hey, I downloaded this framework and installed the most recent fix but when I attempt to add a pack from the compendium I get 'undefined function: pause' and it sits on the updating window endlessly, also for test vs. charactersitic i get 'undefined function: bot_ownergm'. Is there something I am doing wrong?

User avatar
wolph42
Deity
Posts: 9703
Joined: Fri Mar 20, 2009 5:40 am
Location: Netherlands
Contact:

Re: [Dark Heresy-RT-Deathwatch-BC-OW] W40K-RPG_FW v8.4.5

Post by wolph42 »

I have the same issue. for some reason the onCampaignLoad of the BoT does not run on campaign load, which it should. don't know why (yet).
Workaround for now is to select lib:ontokenmove go to the selection panel, scroll down to the yellow buttons and hit the oncampaignload macro.

edit: solved. The ownership was set to all player for lib:ontokenmove. remove all ownership from the token. save. reload.
ive update the campaign as well so you can also redownload it.(same version no)

runecheese30
Kobold
Posts: 2
Joined: Sat Apr 18, 2020 11:17 pm

Re: [Dark Heresy-RT-Deathwatch-BC-OW] W40K-RPG_FW v8.4.5

Post by runecheese30 »

Thank you, good sir. Your framework is great and I appreciate the help.

Snavig
Kobold
Posts: 5
Joined: Wed Apr 15, 2020 2:53 am

Re: [Dark Heresy-RT-Deathwatch-BC-OW] W40K-RPG_FW v8.4.5

Post by Snavig »

Attempting to enable certain modules in the compendium leads to the following errors and the "Processing new settings into the framework... please wait" window to hang around until manually closed.
DW Powers:

Code: Select all

line 1:306: expecting '"', found 'ï'
OW Talents:

Code: Select all

line 1:368: expecting '"', found 'ï'
OW Powers:

Code: Select all

line 1:567: expecting '"', found 'ï'
In addition, targeting multiple tokens (in this case the eagle and dragon provided in the Player Tokens section) with a flamer returns "Error executing "selectTokens": the token name or id "Eagle,Dragon" is unknown."

User avatar
wolph42
Deity
Posts: 9703
Joined: Fri Mar 20, 2009 5:40 am
Location: Netherlands
Contact:

Re: [Dark Heresy-RT-Deathwatch-BC-OW] W40K-RPG_FW v8.4.5

Post by wolph42 »

concerning the doubledotted i...no clue, I've asked the devs to have a look.
concerning the targets, also replicated that issue. trying to figure it out right now

User avatar
wolph42
Deity
Posts: 9703
Joined: Fri Mar 20, 2009 5:40 am
Location: Netherlands
Contact:

Re: [Dark Heresy-RT-Deathwatch-BC-OW] W40K-RPG_FW v8.4.5

Post by wolph42 »

fixed the latter, although i don't understand why its an issue all of a sudden. i cannot update the fw currently so here's the macro code. replace the code in the macro with that name (on lib:darkheresy) with the content of that file....or wait for an update of the fw

edit: figured out the former issue as well. there are a couple of ligatures in the text that maptool chokes on. As far as i can find its only the fi ligature. You can fix this by in the compendium updating the macros of the items that throw an error. Open these, and search and replace:
fi (<--- you need to copy paste that one. Its one character, not two!!)
for
fi (yeah there really is a difference between the two!)
Then run that macro and then run the settings compendium.

or wait for a fix from me
Attachments
processrangedattack.txt
(42.89 KiB) Downloaded 9 times

User avatar
wolph42
Deity
Posts: 9703
Joined: Fri Mar 20, 2009 5:40 am
Location: Netherlands
Contact:

Re: [Dark Heresy-RT-Deathwatch-BC-OW] W40K-RPG_FW v8.4.6

Post by wolph42 »

ok fixed the other issues as well. you can download the compendium and replace it or download the latest version of the FW.
libCompendium.rptok
(825.85 KiB) Downloaded 17 times

Snavig
Kobold
Posts: 5
Joined: Wed Apr 15, 2020 2:53 am

Re: [Dark Heresy-RT-Deathwatch-BC-OW] W40K-RPG_FW v8.4.5

Post by Snavig »

Ok Compendium modules seem to be working fine now, but flamer multiattacks are still not cooperating.
The dodge or evade responses will sometimes work as intended, and sometimes apply damage only to a single target with no attack description in chat and the error

Code: Select all

java.lang.IndexOutOfBoundsException: Index 1 out-of-bounds for length 1 error executing expression zhArray = json.append(zhArray, json.get(zhArray_, roll.count+i)).
Choosing do nothing as a response seems to present this error every time.

User avatar
wolph42
Deity
Posts: 9703
Joined: Fri Mar 20, 2009 5:40 am
Location: Netherlands
Contact:

Re: [Dark Heresy-RT-Deathwatch-BC-OW] W40K-RPG_FW v8.4.7

Post by wolph42 »

ok, fixed that bug as well. Probably more on the way, I don't understand why these all of a sudden are an issue...but we just keep fixing.
Let me know if you find anything else. If you want to upgrade your current campaign file, download the latest version and extra (save) lib:dh and replaced that one in your current campaign file.

Michucz
Kobold
Posts: 6
Joined: Sat May 30, 2020 8:27 pm

Re: [Dark Heresy-RT-Deathwatch-BC-OW] W40K-RPG_FW v8.4.7

Post by Michucz »

Hi Wolph42,
thank you for all this great work, I absolutely love exploring your feamework.

I feel like I'm doing something wrong though, for example when I use the token parser text box i do not get a popup with available items when i have a typo.
I saw this popup window in your youtube video about this framework.
Rather when i have 'Automatically equip unfound gear' set, I get a java nullpointerexception.
Am I missing something?
I am using maptool 1.7
Thanks for any help

Michucz
Kobold
Posts: 6
Joined: Sat May 30, 2020 8:27 pm

Re: [Dark Heresy-RT-Deathwatch-BC-OW] W40K-RPG_FW v8.4.7

Post by Michucz »

Hi again,

my problems unfortunately start with adding things in the compendium.
When i try adding RT Armour i get the following:

Code: Select all

Illegal argument type com.google.gson.JsonArray, expecting java.math.BigDecimal or java.lang.String
Any ideas?
Thanks again for all this great work.

User avatar
wolph42
Deity
Posts: 9703
Joined: Fri Mar 20, 2009 5:40 am
Location: Netherlands
Contact:

Re: [Dark Heresy-RT-Deathwatch-BC-OW] W40K-RPG_FW v8.4.7

Post by wolph42 »

yes, the latest version of maptool (1.5+) exposed some latent bugs in the framework. I've fixed most of them but still havent come round to do an official release, so here's my running campaign: https://www.dropbox.com/s/hfchvoh49obck ... cmpgn?dl=1
what you can do is extract the base map and insert that into your own campaign (AFTER you removed the base map from your campaign file) AND MAKE BACKUPS, not just for this specific case but in general thats good practice!

Michucz
Kobold
Posts: 6
Joined: Sat May 30, 2020 8:27 pm

Re: [Dark Heresy-RT-Deathwatch-BC-OW] W40K-RPG_FW v8.4.7

Post by Michucz »

Thank you so much!
I looked at your campaign file and there is no lib:dh on the base map.
Do I need to use my old one?

Michucz
Kobold
Posts: 6
Joined: Sat May 30, 2020 8:27 pm

Re: [Dark Heresy-RT-Deathwatch-BC-OW] W40K-RPG_FW v8.4.7

Post by Michucz »

Hi again,
I took your campaign file and exported the base map.
Then i deleted the base map from my and imported the new one.
After that i imported the lib:dh from my old campaign file, since i couldn't find one on the base map.
Now i can add things in the compendium again, but when i try to use the textbox parser to parse an enemy for example, i never get the window with suggested gear, instead i get

Code: Select all

java.lang.NullPointerException error executing expression h,if(length(notFound)).

Post Reply

Return to “Campaign Frameworks”