1.4 Build 01

Developer discussion regarding MapTool 1.4

Moderators: Azhrei, dorpond, trevor

Forum rules
Posting now open to all registered forum users.
User avatar
RPTroll
TheBard
Posts: 3148
Joined: Tue Mar 21, 2006 7:26 pm
Location: Austin, Tx
Contact:

Re: 1.4 Build 01

Post by RPTroll »

Possible Bug

I'm having a problem with Wiki: getNotes() and Wiki: getGMNotes(). If I call the function without a note set it errors out. It works fine if there is a note present.

To reproduce:
Drop Token
Impersonate Token
in chat window [r:getNotes()]
witness error

Edit token
Place text in Notes box
Press OK to save
in chat window [r:getNotes()]
witness the note text returned.

[edit: Craig submitted fix]
ImageImage ImageImageImageImage
Support RPTools by shopping
Image
Image

Craig
Great Wyrm
Posts: 2107
Joined: Sun Jun 22, 2008 7:53 pm
Location: Melbourne, Australia

Re: 1.4 Build 01

Post by Craig »

archmagi1 wrote:Is there a big change log for this over 1.3b91? I skimmed upthread, but was just wondering if those snips were the definitive list?

The change list in the announcement was it.
Didn't want to change too much for 1.4.0 and break compatibility so that people on the latest 1.3 would have somewhere to move to easily that works correctly with a recent version of java.

User avatar
Jagged
Great Wyrm
Posts: 1306
Joined: Mon Sep 15, 2008 9:27 am
Location: Bristol, UK

Re: 1.4 Build 01

Post by Jagged »

When I run the current trunk, I get the following run time warnings:

Code: Select all

AppResourceLoader.loadImage failed: net/rptools/lib/image/icons/shape_handles.png
AppResourceLoader.loadImage failed: net/rptools/lib/image/icons/eraser.png
AppResourceLoader.loadImage failed: net/rptools/lib/image/icons/paintbrush.png
AppResourceLoader.loadImage failed: net/rptools/lib/image/icons/contrast_high.png


I assume these should be in the "rpib-1.4.0.1.jar" ? I can see them in the 1.0.b134 version, but not in the 1.4.0.1 version.

Craig
Great Wyrm
Posts: 2107
Joined: Sun Jun 22, 2008 7:53 pm
Location: Melbourne, Australia

Re: 1.4 Build 01

Post by Craig »

Jagged wrote:When I run the current trunk, I get the following run time warnings:

Code: Select all

AppResourceLoader.loadImage failed: net/rptools/lib/image/icons/shape_handles.png
AppResourceLoader.loadImage failed: net/rptools/lib/image/icons/eraser.png
AppResourceLoader.loadImage failed: net/rptools/lib/image/icons/paintbrush.png
AppResourceLoader.loadImage failed: net/rptools/lib/image/icons/contrast_high.png


I assume these should be in the "rpib-1.4.0.1.jar" ? I can see them in the 1.0.b134 version, but not in the 1.4.0.1 version.

I have added these files to the repository. For some reason they are getting excluded by the .gitignore -- I need to revisit all the .gitignore files at some stage.
A new rplib jar has been created (1.4.0.2), because gradle caches the dependency versions for 24 hours by default you will need to run gradle with --refresh-dependencies to pick up the new jar if you have tried in last 24 hours.

Post Reply

Return to “MapTool 1.4”