Weird connection issue

Developer discussion regarding MapTool 1.4

Moderators: Azhrei, dorpond, trevor

Forum rules
Posting now open to all registered forum users.
Post Reply
EngineMedic7
Kobold
Posts: 3
Joined: Sun Jun 02, 2019 9:24 am

Weird connection issue

Post by EngineMedic7 »

So I've been playing via MapTools for years now, yesterday when I tried to connect to the GM for a game, my connection timed out. It timed out for other open games and other servers as well, however I was able to host it.

I have AVG Antivirus, but I disabled all of it and still time out. I ran a cmd /ping and the ping times out, however a /tracert works just fine. This occurred from both my desktop and laptop PCs. I then took my laptop to work and connected to a different network with the same results.

I read through the networking guide for MT but my problem isn't identified there.

Looking for help from the gurus here so I can figure out how to fix this issue.

User avatar
Full Bleed
Demigod
Posts: 4444
Joined: Sun Feb 25, 2007 11:53 am
Location: MD
Contact:

Re: Weird connection issue

Post by Full Bleed »

EngineMedic7 wrote:
Sun Jun 02, 2019 9:41 am
Looking for help from the gurus here so I can figure out how to fix this issue.
I would try uninstalling Java and then reinstalling it, making sure to accept the windows security exception when you run MT for the first time after the Java re-install.

PS: Make sure you download the 64 bit version of Java.
Maptool is the Millennium Falcon of VTT's -- "She may not look like much, but she's got it where it counts."

User avatar
aliasmask
Deity
Posts: 8579
Joined: Tue Nov 10, 2009 6:11 pm
Location: Bay Area

Re: Weird connection issue

Post by aliasmask »

Also, if you suspect a java issue, restart your computer after removing. This is actually an important step.

Phergus
Deity
Posts: 7108
Joined: Fri May 12, 2006 8:56 pm
Location: Middle of Nowhere, NM
Contact:

Re: Weird connection issue

Post by Phergus »

First, what version of MapTool? This matters as current versions have the Java JRE bundled inside the install where as older versions did not.
EngineMedic7 wrote:
Sun Jun 02, 2019 9:41 am
..., yesterday when I tried to connect to the GM for a game, my connection timed out. It timed out for other open games and other servers as well,...
If you get a Connection Timed Out message as a player, the problem is usually on the GM's side.

However, a change to your firewall software or Java install - for older versions of MT that use separate Java installs - can impact you as a player trying to connect. This would explain being unable to connect to other servers as well. It's not clear what you mean when you say "open games" vs. "other servers".

Glendwyr
Kobold
Posts: 11
Joined: Mon Apr 11, 2016 4:11 am

Re: Weird connection issue

Post by Glendwyr »

Importantly, we're using 1.4.1.8 so it should be the bundled JRE. At the time I had two other players connected without problems, fwiw. Experimentation continues!

Edit to add: connection went off without a hitch using the same computers on both his end and mine, but connecting from his workplace rather than from his home.

EngineMedic7
Kobold
Posts: 3
Joined: Sun Jun 02, 2019 9:24 am

Re: Weird connection issue

Post by EngineMedic7 »

Phergus wrote:
Mon Jun 03, 2019 8:34 am
First, what version of MapTool? This matters as current versions have the Java JRE bundled inside the install where as older versions did not.
EngineMedic7 wrote:
Sun Jun 02, 2019 9:41 am
..., yesterday when I tried to connect to the GM for a game, my connection timed out. It timed out for other open games and other servers as well,...
If you get a Connection Timed Out message as a player, the problem is usually on the GM's side.

However, a change to your firewall software or Java install - for older versions of MT that use separate Java installs - can impact you as a player trying to connect. This would explain being unable to connect to other servers as well. It's not clear what you mean when you say "open games" vs. "other servers".
What I was referring to is attempting to connect to non-password protected games in the server list. As my GM stated, others were able to connect and then also I was able to connect at work. I'm leaning towards an ISP issue but even disabling my firewalls completely at home I'm getting nothing, it's really weird because we've never had issues connecting before

EngineMedic7
Kobold
Posts: 3
Joined: Sun Jun 02, 2019 9:24 am

Re: Weird connection issue

Post by EngineMedic7 »

So it gets even weirder....

I made it back home, been working with my GM all week on this. Did a hard reset on the router. uninstalled an reinstalled java and MT; system reboot, everything. Still couldnt connect.
Set up a port forward - nothing
set up a DMZ - nothing

connected to the "xfinitywifi" (free wifi for xfinity customers) which piggybacks off my signal.... and it connects. Then I switched BACK to my secure network, and it connected... on one computer, but not the other.

This literally makes ZERO sense to me.

Post Reply

Return to “MapTool 1.4”