Inittool 1.1b9 not loading

Discussion of initiative tool.

Moderators: Azhrei, dorpond

patrick.h.hart
Kobold
Posts: 1
Joined: Thu Jun 24, 2010 12:47 pm

Re: Inittool 1.1b9 not loading

Post by patrick.h.hart »

Running OS X 10.6.4

Of all the tools, InitTool-11b9-512m-2m.jnlp is the only one that didn't run correctly. It would hang at the splash screen @ the end of it's initial DL.

A little poking around shows that the app is throwing an exception here...

FormManagerUtils.openPackgedForm failed: net/rptools/inittool/resources/forms/creatureIndexCard.jfrm
java.io.IOException: Stream closed
...


BTW: The zip version of the app (1.1b9) opened with 'Launch InitTool.sh' works fine.

User avatar
jay
RPTools Team
Posts: 1767
Joined: Tue Feb 07, 2006 1:07 am
Location: Austin, Tx
Contact:

Re: Inittool 1.1b9 not loading

Post by jay »

For some reason, Web Start will not read some of the data files within the jar. It only does this some times and it only does it for certain people. I've seen it fail on one build, then rebuilt the same code and have it work for the next. I've never been able to figure out why so that I can fix it. The only workaround I have is to download the zip file and run it locally.

User avatar
jay
RPTools Team
Posts: 1767
Joined: Tue Feb 07, 2006 1:07 am
Location: Austin, Tx
Contact:

Re: Inittool 1.1b9 not loading

Post by jay »

Azhrei wrote:Jay, here's the command line as reported by ps that Java Web Start created when launched on OSX. Does anything here stand out to you?

snip...

Interestingly enough, that filename tacked onto the end, /var/tmp/javawsXRQJqa, which is obviously a temporary file of some kind, doesn't exist on my system :?
Nothing stands out because it is all going to start the Web Start application. That last file is just a string parameter to the application, so it could be a temp file that Web Start was going to create for logging or whatever.

Post Reply

Return to “InitiativeTool”