Problem with Vision in 1.7.0

Thoughts, Help, Feature Requests, Bug Reports, Developing code for...

Moderators: Azhrei, dorpond, trevor

Forum rules
PLEASE don't post images of your entire desktop, attach entire campaign files when only a single file is needed, or generally act in some other anti-social behavior. :)
Post Reply
User avatar
TheIneffableCheese
Cave Troll
Posts: 62
Joined: Sun Mar 22, 2015 3:57 pm

Problem with Vision in 1.7.0

Post by TheIneffableCheese »

Hi all,

The night before last I ran my game using MT 1.7.0 for the first time, and I ran into an issue that I've not seen before.

My players were in an underground setting, and I had set the map's vision to "Night" - player tokens all have appropriate sight settings on the Config tab, and ownership of the various tokens was set correctly.

On the GM server side of things, everything looked fine - light sources were projecting as expected, character sight was revealing the FoW as expected when I moved player tokens a little bit onto the map, etc. However, on the player side of things, they could not see any of their tokens even when they should have been able to. They could see the token as I moved them, but as soon as I released the mouse button the token would disappear.

This behavior persisted when I switched from "Night" to "Day," but as soon as I turned the map's vision setting to "Off" everyone could see their tokens just fine. We ended up playing the rest of the night that way, so it wasn't a huge deal, but dynamic lighting and vision is one of my favorite things about MapTool.

This morning I ran a quick test by setting up a server in one instance of MapTool and connecting as a player through another instance on my machine, and I observed the same behavior. Minimizing the windows, I set up the server and the client so they were visible at the same time. When either Night or Day was set, the player view could not see any of the tokens unless the GM view was actively moving them; the GM view showed everything as expected.

This was run from a campaign file which was copied from the last campaign file I used (on 1.5.something-greater-than-10), and we never had a problem with it - I had used it both in person in a dual screen set up and over the internet after the lockdown started.

I'm assuming that this is some setting that has gotten screwed up, and most probably if I flip the right switch everything will work fine. I'm hoping someone might be able to point me to the issue so I can fix it.

Thanks in advance!

User avatar
Full Bleed
Demigod
Posts: 4444
Joined: Sun Feb 25, 2007 11:53 am
Location: MD
Contact:

Re: Problem with Vision in 1.7.0

Post by Full Bleed »

TheIneffableCheese wrote:
Fri Jun 19, 2020 1:10 pm
I'm hoping someone might be able to point me to the issue so I can fix it.
You should share the campaign.
Maptool is the Millennium Falcon of VTT's -- "She may not look like much, but she's got it where it counts."

User avatar
TheIneffableCheese
Cave Troll
Posts: 62
Joined: Sun Mar 22, 2015 3:57 pm

Re: Problem with Vision in 1.7.0

Post by TheIneffableCheese »

Campaign file attached.

I did (I think) figure out a work around. When I set the server settings to "Individual Views" and "Individual FoW" it seems to work as expected on the client side. I'll be playing again on Wednesday evening - hopefully I'll have some real world feedback at that point.
Attachments
5e_MasterFile.cmpgn
(4.1 MiB) Downloaded 6 times

Merudo
Giant
Posts: 228
Joined: Wed Jun 05, 2019 7:06 am

Re: Problem with Vision in 1.7.0

Post by Merudo »

Changing the tokens from NPCs to PCs fixed the issue.

Seems like this is a bug with NPC tokens and shared vision.

User avatar
TheIneffableCheese
Cave Troll
Posts: 62
Joined: Sun Mar 22, 2015 3:57 pm

Re: Problem with Vision in 1.7.0

Post by TheIneffableCheese »

Just confirmed. That fixed it.

Thanks so much!

Post Reply

Return to “MapTool”